Reply
 
Thread Tools Display Modes
Old 10-30-2017, 08:39 PM   #1
Junior Member
 
Join Date: Feb 2017
Posts: 3
Water Issues!

I have a 2015 Forest River Surveyor 32rlts. Hooked up the water to the city connection and after about 2 hours I noticed water leaking from under the camper. It had crossed over somehow to the fresh water tank and was over flowing. I have never even used the fresh water tank. Always used city hook up at campgrounds. I can not find a valve anywhere that may of been bumped open accidentally. Does anyone have any ideas or a water schematic for this particular camper? TIA!
__________________

Aquanet is offline   Reply With Quote
Old 10-30-2017, 08:47 PM   #2
Senior Member
 
Join Date: Feb 2017
Posts: 152
likely the check valve in the water pump got stuck open. I have seen many posts this year with the exact same problem. I am not sure but, I think the remedy is to turn off the city water, relieve the pressure of the system and either adjust the pressure switch on the pump (set screw), or open up the filter screen housing on the pump and hope that the check valve springs back into proper position.

Good luck.
__________________

slimetime is offline   Reply With Quote
Old 10-30-2017, 08:47 PM   #3
Scoundrel
 
HangDiver's Avatar
 
Join Date: Feb 2017
Location: Palm Bay, Florida
Posts: 1,472
Common problem when the check valve on the water pump doesn't seat properly. Cut off the water supply from your City water connection. Turn on your water pump and run a faucet or two for about a minute. Turn off water pump and reconnect to city water - that should reset the valve.

Good luck.
__________________
2014 Micro Lite 19fd
2015 F-150 5.0L V8 XLT Crew Cab, 4x4, Tow Package, 36 gal tank, 3.55 locker, 1891 payload, Integrated Brake Controller

Wooden Spoon Survivor
HangDiver is offline   Reply With Quote
Old 10-30-2017, 08:49 PM   #4
Senior Member
 
rracer5's Avatar
 
Join Date: Jan 2011
Location: Full Timing It
Posts: 2,450
Quote:
Originally Posted by HangDiver View Post
Common problem when the check valve on the water pump doesn't seat properly. Cut off the water supply from your City water connection. Turn on your water pump and run a faucet or two for about a minute. Turn off water pump and reconnect to city water - that should reset the valve.

Good luck.

X2
__________________
"PT Crew Members Since 9/2010"
2011 RAM 2500 HD 6.7L CTD Crew
2014 Sanibel 3250
rracer5 is offline   Reply With Quote
Reply

Tags
water

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by


Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:16 PM.