Reply
 
Thread Tools Display Modes
Old 08-10-2012, 10:31 PM   #1
2011 Sunseeker 3120
 
Garbet's Avatar
 
Join Date: Sep 2011
Location: Ontario, Canada
Posts: 24
Water Pump

We noticed the water pump started running on in our sunseeker 3120 this weekend. Not sure where it's located. R they normally near the water heater area or the bathroom area and would it be on the inside or outside?

thanks in advance

Garry
__________________

__________________
Garbet is offline   Reply With Quote
Old 08-11-2012, 01:24 AM   #2
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Quote:
Originally Posted by Garbet
We noticed the water pump started running on in our sunseeker 3120 this weekend. Not sure where it's located. R they normally near the water heater area or the bathroom area and would it be on the inside or outside?

thanks in advance

Garry
Garbet,
Were you using the fw tank or hooked to city water connection?

If you were using fw tank and pump ran for no apparent reason you most likely have air in the system .

Pump should not run using city water connection. Nor should you need it on when using city water connection.
Unless someone turned on switch for pump.

Pump is normally near city water/fw fill location on the inside of coach.

Panels may need to be removed to access it. There most likely is a water filter nearby.

Ron
__________________

__________________
TURBS is offline   Reply With Quote
Old 08-11-2012, 08:22 AM   #3
2011 Sunseeker 3120
 
Garbet's Avatar
 
Join Date: Sep 2011
Location: Ontario, Canada
Posts: 24
Thanks Ron. Will b checking this out, asap.

Gary
__________________
Garbet is offline   Reply With Quote
Old 08-13-2012, 06:58 AM   #4
Junior Member
 
Join Date: Jul 2012
Location: 2283 Lost Creek Road Sinking Spring, PA 19608
Posts: 3
I am agree with Ron. Much appreciated !
__________________
Dean Haviland is offline   Reply With Quote
Old 08-13-2012, 07:36 AM   #5
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,169
With city water pressure (unless VERY low) the pump should never run.
(though my camper has a sticker that says not to turn it on with city water pressure). There is a pressure switch that turns the pump off. If city water pressure is keeping the pump "happy", it should never run even.
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 08-18-2012, 06:09 PM   #6
2011 Sunseeker 3120
 
Garbet's Avatar
 
Join Date: Sep 2011
Location: Ontario, Canada
Posts: 24
Water Pump

Yes. I found the pump tucked in behind next to the water filter system. The in-line screen filter was clear. Fresh water tank under the bed, filled it up and everything seems fine. A tap must not have been closed tight, or air in the system which made the pump run on.
I was on city water and pressure seemed to be ok until that happened!
Thanks again for all your help.

Gary
__________________

__________________
Garbet is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:46 AM.