Reply
 
Thread Tools Display Modes
Old 01-19-2016, 12:07 PM   #1
Member
 
Join Date: Jan 2014
Posts: 50
Thumbs up Water pump

Has anyone here on the forum ever changed a water pump in a FR Cedar Creek (38FL) 2014 5th wheel or some unit that's a close match. Also does anyone have a picture or some instructions of some sort on a DYI project or just a someone know how.
I want to repair or replace pump
I don't know if it's me or people haven't done this project because I normally just get one response. I am in this forum almost 3x's a week and read long threads but my threads go nowhere. Maybe I'm missing a step. Anyway I'm looking for advice or pictures of water pump.
Should I put this thread in "general discussion" to get more feedback
Thanks in advance to all.
__________________

__________________
craigi is offline   Reply With Quote
Old 01-19-2016, 12:35 PM   #2
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 3,237
Lots of info on youtube.......

https://www.youtube.com/results?sear...ter+pump+in+rv
__________________

__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2008 F250 Lariat CC SB 6.8L V10 4.10 axle ratio (NITTO TERRA GRAPLER G2 LT275/65R20E)
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2011(21) 2012(36) 2013 (17) 2014 (18) 2015 (18) 2016 (36) 2017 (32)
fonzie is online now   Reply With Quote
Old 01-19-2016, 12:59 PM   #3
Senior Member
 
Join Date: Jul 2010
Location: Waynesville
Posts: 12,036
Quote:
Originally Posted by craigi View Post
Has anyone here on the forum ever changed a water pump in a FR Cedar Creek (38FL) 2014 5th wheel or some unit that's a close match. Also does anyone have a picture or some instructions of some sort on a DYI project or just a someone know how.
I want to repair or replace pump
I don't know if it's me or people haven't done this project because I normally just get one response. I am in this forum almost 3x's a week and read long threads but my threads go nowhere. Maybe I'm missing a step. Anyway I'm looking for advice or pictures of water pump.
Should I put this thread in "general discussion" to get more feedback
Thanks in advance to all.
You are correct in your disappearing Post's! Like you say a Post of My Dog is Left Pawed,will go on for 7 pages! Now back to your Q,if you were happy with the O/E Pump just replace with same,But if you use your Pump often (Dry Camp or In the Night) I would really consider also installing a Pressure/Bladder Tank at the same time! If you install a 3-5 Gal size tank your F/W system will then be just like your Home,and the pump wont run Everytime you turn on a Fixture! The Tank can be mounted ANYWHERE in your cold water pressure side of the system! Nice smooth showers also! Youroo!! PS Do you have a Dog?
__________________
youroo is offline   Reply With Quote
Old 01-19-2016, 01:03 PM   #4
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
I have nothing to add other then to agree with Youroo.



2015 Columbus 320RS
2008 2500HD Duramax
2015 nights camped "34"
__________________
TURBS is offline   Reply With Quote
Old 01-19-2016, 04:37 PM   #5
Site Team
 
Mr. Dan's Avatar
 
Join Date: Mar 2014
Location: Grayson County, Texas
Posts: 6,272
I can't help you with "FR Cedar Creek (38FL) 2014 5th wheel or some unit that's a close match" because I have a different unit and most of us don't know if our units are a close match to yours... units are so different on this forum. Sorry.

I don't understand why your "posts go nowhere". Usually when someone posts the statement "I want to repair or replace pump", someone (or two) asks "Why do you think you need to replace or repair your pump?"

So, I'll ask. What symptoms are you having? Does it run and not pump? Does it not run?
__________________
SEARCH is your friend!
FR Wildcat 295RSX / GMC Sierra

Nights Camped: '13 = 49 / '14 = 74 / '15 = 74 / '16 = 85 / '17 = 110 / '18 = 0; booked = 28
Mr. Dan is offline   Reply With Quote
Old 01-20-2016, 10:57 AM   #6
Member
 
Join Date: Jan 2014
Posts: 50
Pump was running, because I could hear it but was not pumping water to the house. I would leave running for a good while. Now when I turn on pump I can't hear anything. I've checked fuse panel and all looks good. Not sure if there is an inline fuse. I'm just assuming it's on the lamb.
I'm in the process of locating it and removing it. I just really wanted to get some feedback from our great forum people.
Thanks for answering.
Craig........happy trails again
__________________
craigi is offline   Reply With Quote
Old 01-20-2016, 11:02 AM   #7
Senior Member
 
Join Date: Jul 2010
Location: Waynesville
Posts: 12,036
Most have a Fuse rite at the Pump area! Makes it handy when pumping anti-freeze! good luck with your pump issue,might check if there are any Suction leaks between the Pump and the F/W tank also! Youroo!!
__________________
youroo is offline   Reply With Quote
Old 01-20-2016, 11:02 AM   #8
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
There is an inline fuse right at the pump.

On your other question "threads go no where"
When it's busy on this forum threads get buried FAST!


2015 Columbus 320RS
2008 2500HD Duramax
2015 nights camped "34"
__________________
TURBS is offline   Reply With Quote
Old 01-20-2016, 11:07 AM   #9
Phat Phrog Stunt Team
 
AquaMan's Avatar
 
Join Date: Apr 2012
Location: Tipp City, OH
Posts: 6,477
The pump replacement "should" be an easy fix. Most likely it is connected to the water lines with threaded fittings and screwed down to a wooden base with a few screws. At least all that I have replaced or seen, have been this way. Takes about 15min to change one out, and most of that time is trying to get to it.
__________________
2016 Georgetown 364TS
Nights Camped 2017 - 49
AquaMan is offline   Reply With Quote
Old 01-20-2016, 11:19 AM   #10
Senior Member
 
Ford Idaho's Avatar
 
Join Date: Sep 2013
Location: Idaho
Posts: 9,840
My lite had a problem like this, it would pump water but it was pathetic.

Took it back to the dealer and had them find and fix the problem, turned out it was a loose connection at the intake side of the pump it was sucking as much air as water.

On mine.



Pass thru door to the left of docking station.

Inside right side of the pass thru is a panel, 4 #2 Robertson screws need to be removed.

Pump is right there.

I figure 1 to 1 1/2 hours with a beer break to replace.

__________________

__________________
2016 F350 6.7L LB CC Reese 28K 2014 Chaparral Lite 266sab
"Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety." 2014 19 days camping 2015 17 days camping201620 days camping
Ford Idaho is offline   Reply With Quote
Reply

Tags
pump, water, water pump

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:54 PM.