Reply
 
Thread Tools Display Modes
Old 06-01-2015, 11:56 AM   #1
Senior Member
 
Join Date: Oct 2014
Posts: 112
12 Volt Power Issue Windjammer 3008W

While I was pulling the slide in my husband disconnected the 110 power cord. I then lost all power to the trailer. Plugged it back in to shore power there was a lag time before it came back on again but now when disconnected from shore power we have no power at all in the trailer. The battery is charged and when connected to the tow vehicle we only have power if the truck is running which is weird. Where is the power converter on a 2015 Windjammer 3008W or is there a main fuse for 12 volt operation?? We also had the surge protector on. Any ideas would be greatly appreciated. Thanks
__________________

__________________
CLewis is offline   Reply With Quote
Old 06-01-2015, 12:05 PM   #2
Member
 
Join Date: Sep 2013
Location: Western Penna.
Posts: 68
12 volt

check your disconnect switch. up front by the propane bottles.
__________________

__________________
2OLDDIGGERS is offline   Reply With Quote
Old 06-01-2015, 12:12 PM   #3
Senior Member
 
Join Date: Oct 2014
Posts: 112
Already did that - I wish that was the problem. Thanks
__________________
CLewis is offline   Reply With Quote
Old 06-01-2015, 12:18 PM   #4
Senior Member
 
D_B Travelers's Avatar
 
Join Date: Mar 2014
Location: Watauga, Texas
Posts: 688
Also, remember the surge protector has a built-in delay of about 2-1/2 minutes. Or my Progressive does anyway. The battery may be charged and show 12+ volts, but you may want to take it and have it checked under load at a shop. I have had a battery that checked good on volts but didn't have enough amps when a load was applied. You said everything was dead. Interior lights also?
__________________
D_B Travelers - 8 nights in 2017, 35 nights in 2016. [U]1st love: 2014 TT WJ3001w, now 2016 FW SOB, 2015 GMC 3500HD CC DRW Duramax, TST 507rv TPMS.
"Happiness? A good meal, a good cigar and a good woman - or a bad woman; it depends on how much happiness you can handle."
George Burns (1896 1996)
D_B Travelers is offline   Reply With Quote
Old 06-01-2015, 12:34 PM   #5
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 3,236
Check underneath trailer near tongue for a mini-breaker and press black button to reset. Hope that will do it.
Attached Thumbnails
Click image for larger version

Name:	mini-breaker pic.jpg
Views:	112
Size:	30.1 KB
ID:	78704  
Attached Images
 
__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2008 F250 Lariat CC SB 6.8L V10 4.10 axle ratio (NITTO TERRA GRAPLER G2 LT275/65R20E)
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2011(21) 2012(36) 2013 (17) 2014 (18) 2015 (18) 2016 (36) 2017 (32)
fonzie is offline   Reply With Quote
Old 06-01-2015, 12:56 PM   #6
Senior Member
 
Join Date: Oct 2014
Posts: 112
All lights are off and looked we don't have the black button under the a frame. Thanks
__________________
CLewis is offline   Reply With Quote
Old 06-01-2015, 01:30 PM   #7
Senior Member
 
D_B Travelers's Avatar
 
Join Date: Mar 2014
Location: Watauga, Texas
Posts: 688
Oh boy, then I am thinking that the converter has died perhaps. I hope you have some other responses on this, but I have no experience troubleshooting the converter...yet. I will keep an eye on the thread so I can learn also.
__________________
D_B Travelers - 8 nights in 2017, 35 nights in 2016. [U]1st love: 2014 TT WJ3001w, now 2016 FW SOB, 2015 GMC 3500HD CC DRW Duramax, TST 507rv TPMS.
"Happiness? A good meal, a good cigar and a good woman - or a bad woman; it depends on how much happiness you can handle."
George Burns (1896 1996)
D_B Travelers is offline   Reply With Quote
Old 06-01-2015, 01:31 PM   #8
Senior Member
 
Join Date: Nov 2014
Posts: 505
Battery

Battery dead or not connected. Have it tested.
__________________
Harkerr is offline   Reply With Quote
Old 06-01-2015, 01:39 PM   #9
Senior Member
 
Join Date: Oct 2014
Posts: 112
That was my husbands next thing to do. The battery shows fully charged by he's thinking he should have it tested with a load on it. Hopefully it is just the battery.
__________________
CLewis is offline   Reply With Quote
Old 06-01-2015, 01:47 PM   #10
Senior Member
 
Eaglelover's Avatar
 
Join Date: Nov 2011
Location: Chenango County NY
Posts: 172
Send a message via Skype™ to Eaglelover
If when you plug back in and have 12v power then the converter should not be the problem. I would connect a set of jumper cables to the TT battery and see if you get power. Frank
__________________

__________________
Eaglelover is offline   Reply With Quote
Reply

Tags
12 volt, 3008w, power, windjammer

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:58 PM.