Thread Tools Display Modes
Old 05-08-2015, 09:16 PM   #11
Senior Member
Join Date: Nov 2012
Location: Winnipeg
Posts: 673
Agree with flybob, if everything worked fine before the TV fell off the mount and now you have a dead short, it would seem to me that the problem is at or near the wall plate wiring!!

Of all the things I've lost in my life the thing I miss the most is my mind!
prairiecamper is offline   Reply With Quote
Old 05-08-2015, 09:22 PM   #12
Senior Member
onetonford's Avatar
Join Date: Oct 2010
Posts: 494
Could be the wiring under the slide out for the lights I have seen them break from opening and closing slide you might check there.


2001 Ford F-350 DRW 7.3
2011 25 RL Wildcat
former fiver 1976 Fourwinds had for 35 years
onetonford is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:09 PM.