Reply
 
Thread Tools Display Modes
Old 05-21-2013, 07:53 PM   #1
Junior Member
 
Join Date: May 2012
Posts: 10
12v Problems

Surveyor sv180t
WF Converter

On the way home from a trip, lost 12v power

Hooked up to shore power, no problems.

Battery tested good, putting out 13

Checked fuses, tripped breakers, still no power when not connected to shore.

No voltage reading at terminal where the battery wires come into the WC converter.

Next step?

Thank you for any advice before I have to haul it in to a repair shop
__________________

__________________
Desmo13 is offline   Reply With Quote
Old 05-21-2013, 08:06 PM   #2
Site Team
 
wmtire's Avatar
 
Join Date: Nov 2010
Location: Northeast Louisiana
Posts: 15,002
There is usually a fuse (sometimes a resettable type circuit breaker) between the battery and converter. You'll need to look along your frame rail to find it, if nobody else chimes in with a location.
__________________

__________________
2011 Flagstaff 831 RLBSS

Ducks are just all-terrain chickens
wmtire is online now   Reply With Quote
Old 05-21-2013, 08:09 PM   #3
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,336
Quote:
Originally Posted by wmtire View Post
There is usually a fuse (sometimes a resettable type) between the battery and converter. You'll need to look along your frame rail to find it, if nobody else chimes in with a location.
X2
__________________
TURBS is offline   Reply With Quote
Old 05-21-2013, 08:13 PM   #4
Senior Member
 
crunchman12001's Avatar
 
Join Date: Feb 2013
Location: Chagrin Falls, Ohio
Posts: 3,072
Quote:
Originally Posted by wmtire View Post
There is usually a fuse (sometimes a resettable type) between the battery and converter. You'll need to look along your frame rail to find it, if nobody else chimes in with a location.
X2 Make sure to check wires in that box for lose connections. Also, check wires at battery disconnect switch if equipped. My ground wire came out of the eyelet when I bumped the wires. Nice and tight now.
crunchman
__________________
2017 Salem Villa Estate 395RET-
2011 Coachmen Freedom Express 295RLDS- Sold
2015 F-250 FX4
crunchman12001 is online now   Reply With Quote
Old 05-21-2013, 10:10 PM   #5
Junior Member
 
Join Date: May 2012
Posts: 10
thank you all, I can't find the inline fuse. the bottom of my trailer has a cover, probably under there? anyone know.
__________________
Desmo13 is offline   Reply With Quote
Old 05-21-2013, 10:15 PM   #6
Site Team
 
wmtire's Avatar
 
Join Date: Nov 2010
Location: Northeast Louisiana
Posts: 15,002
Quote:
Originally Posted by Desmo13 View Post
thank you all, I can't find the inline fuse. the bottom of my trailer has a cover, probably under there? anyone know.

EDIT: I see your trailer model now in the opening post

Did you see anything that looked similar to this?

__________________
2011 Flagstaff 831 RLBSS

Ducks are just all-terrain chickens
wmtire is online now   Reply With Quote
Old 05-21-2013, 10:35 PM   #7
DDC
Senior Member
 
DDC's Avatar
 
Join Date: Sep 2011
Location: Komoka Ontario
Posts: 2,363
Test lite from pos term. to the frame to test the ground from the battery.If you don't have a test lite get one jumper cable connect to neg term. then connect the other end to the frame and check interior lights. The ground is the most common problem in 12 volt faults.
__________________
"Well that didn't go as expected"
2015 Chev 2500HD Highcountry Duramax
Cedar Creek Silverback 33IK
Donald&Casey cairn terrier
Rest in Peace Mary my darling wife.
Scottish by birth Canadian by time.
DDC is offline   Reply With Quote
Old 05-22-2013, 12:25 AM   #8
Moderators' Assistant
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 13,253
Quote:
Originally Posted by Desmo13 View Post
thank you all, I can't find the inline fuse. the bottom of my trailer has a cover, probably under there? anyone know.
the resettable fuse that WMTire posted a pic of, is along the A-frame, not in the bottom of your trailer.
__________________
Dan-Retired Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
2016 PrimeTime TracerAIR 255, pushing a 2014 Ford F150 4x4 3.5 Ecoboost w/Max Tow Package
Equalizer WDH and Prodigy BC
bikendan is online now   Reply With Quote
Old 05-25-2013, 12:07 AM   #9
Junior Member
 
Join Date: May 2012
Posts: 10
Problem solved, the first thing I should have checked. Rust/corrosion on the battery ground wire connection. I still never fund the inline fuse though
__________________

__________________
Desmo13 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:24 PM.