Reply
 
Thread Tools Display Modes
Old 09-15-2012, 02:02 PM   #1
Junior Member
 
Join Date: Sep 2012
Posts: 2
30 amp fuses blowing battery power only

The 30 amp fuses are blowing, The shore power is not hooked up, Battery polarity is correct, When shore power is attached here is no voltage between the blue wire and the ground in the converter. Everything tells me the converter is bad. Sombody please correct me .

general tinkerer but not an expert by any means

Thanks
Bill
__________________

__________________
Bioteach is offline   Reply With Quote
Old 09-15-2012, 02:38 PM   #2
Senior Member
 
Iggy's Avatar
 
Join Date: Jul 2010
Location: Desert SW - Arizona
Posts: 6,359
Quote:
Originally Posted by Bioteach View Post
The 30 amp fuses are blowing, The shore power is not hooked up, Battery polarity is correct, When shore power is attached here is no voltage between the blue wire and the ground in the converter. Everything tells me the converter is bad. Sombody please correct me .

general tinkerer but not an expert by any means

Thanks
Bill

If you are getting power into the converter and no output from the converter your converter is bad.
__________________

__________________
2012 Georgetown XL - 378TS 60,000 miles
Life is a journey, not a destination !

Iggy is offline   Reply With Quote
Old 09-15-2012, 03:37 PM   #3
Moderator Emeritus
 
Triguy's Avatar
 
Join Date: Aug 2010
Location: Southeast Wisconsin
Posts: 6,950
I'd have to agree. Although you could look to try and repair, they're not typically expensive to replace.

What model converter do you have and what year and model trailer?

Welcome by the way.
__________________
Scott
DW, 3 Kids and our Goldens

2012 Shamrock 233S
2008 Toyota Sequoia 5.7L 4WD
Triguy is offline   Reply With Quote
Old 09-15-2012, 04:54 PM   #4
Moderator Emeritus
 
Dave_Monica's Avatar
 
Join Date: Sep 2007
Location: Ontario, Canada
Posts: 4,329
Quote:
Originally Posted by Iggy View Post
If you are getting power into the converter and no output from the converter your converter is bad.
I'd agree about the converter, but would that explain why the OP is blowing the 30A fuse off the battery when shorepower isn't connected. Is the dead converter creating a short to ground on the 12V side?

Dave
__________________


Nights camped in 2013 - 55, 2014 - 105, 2015 - 63
Dave_Monica is offline   Reply With Quote
Old 09-15-2012, 05:01 PM   #5
Junior Member
 
Join Date: Sep 2012
Posts: 2
Quote:
Originally Posted by Triguy View Post
I'd have to agree. Although you could look to try and repair, they're not typically expensive to replace.

What model converter do you have and what year and model trailer?

Welcome by the way.
Thanks for the welcome

We are newbies and started with a 2009 Wilcat 25rl The converter and panel are a Parallex 7100 55 amp
Bill
__________________
Bioteach is offline   Reply With Quote
Old 09-17-2012, 11:49 AM   #6
Moderator Emeritus
 
Triguy's Avatar
 
Join Date: Aug 2010
Location: Southeast Wisconsin
Posts: 6,950
Quote:
Originally Posted by Dave_Monica View Post
I'd agree about the converter, but would that explain why the OP is blowing the 30A fuse off the battery when shorepower isn't connected. Is the dead converter creating a short to ground on the 12V side?

Dave
I'm not sure "why" it would. Rumor has it there may have been a problem in 2008 with this Parallax power center. I hate to link to another site , but here's a description. The solution was to replace the circuit board or replace the whole unit.

We don't see many Parallax here so I've added some manuals for Bill. Maybe this will help.
Attached Files
File Type: pdf Parallax 7100 converter manual.pdf (107.0 KB, 68 views)
File Type: pdf Parallax 7100 Series Installation Guidelines.pdf (485.8 KB, 49 views)
__________________
Scott
DW, 3 Kids and our Goldens

2012 Shamrock 233S
2008 Toyota Sequoia 5.7L 4WD
Triguy is offline   Reply With Quote
Old 09-17-2012, 11:58 AM   #7
Moderator Emeritus
 
Triguy's Avatar
 
Join Date: Aug 2010
Location: Southeast Wisconsin
Posts: 6,950
This one is more clear on how to troubleshoot...
Attached Thumbnails
Click image for larger version

Name:	Capture.jpg
Views:	187
Size:	64.9 KB
ID:	19598  
Attached Files
File Type: pdf PPS 7100 Series Diagnostic .pdf (634.3 KB, 89 views)
__________________
Scott
DW, 3 Kids and our Goldens

2012 Shamrock 233S
2008 Toyota Sequoia 5.7L 4WD
Triguy is offline   Reply With Quote
Old 09-17-2012, 12:55 PM   #8
Senior Member
 
Iggy's Avatar
 
Join Date: Jul 2010
Location: Desert SW - Arizona
Posts: 6,359
Quote:
Originally Posted by Triguy View Post
This one is more clear on how to troubleshoot...

Great troubleshooting chart
__________________

__________________
2012 Georgetown XL - 378TS 60,000 miles
Life is a journey, not a destination !

Iggy is offline   Reply With Quote
Reply

Tags
battery

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:55 PM.