Reply
 
Thread Tools Display Modes
Old 08-18-2015, 03:24 PM   #1
Senior Member
 
Join Date: Apr 2013
Location: Santa Fe, Tx
Posts: 200
30amp surge protector.

Have a progressive 30 amp that is suppose to be hardwired, but in a place that is extremely hard to get to(behind the oven) per the tech who installed it I now question weather he did or not. Is there any way to tell if its hookedup ot even there? If I remove the screwsfron the front of the convertor and look behind the plate will there be any noticable wires?
Probably a stupid question but I don't have a clue with electric
__________________

__________________
2012 F250 6.2 gasser 373 rear
2013 Rockwood 2104S Mini Lite
Ole Buzzard is offline   Reply With Quote
Old 08-18-2015, 03:43 PM   #2
Senior Member
 
HONDAMAN174's Avatar
 
Join Date: Jun 2011
Location: Big brown desert
Posts: 2,318
Plug in to shore power. If it takes 15 seconds to turn on, he installed it. If power comes immeaditly then he didn't.
__________________

__________________
2014 Stealth Evo 2850- "Woodstock"
2011 Toyota Tundra Rock Crawler TRD 5.7- "Clifford"
2013 Honda Accord Coupe V6 w/Track Pack- "Julia"

Just glad to get away
HONDAMAN174 is offline   Reply With Quote
Old 08-18-2015, 03:44 PM   #3
Senior Member
 
HONDAMAN174's Avatar
 
Join Date: Jun 2011
Location: Big brown desert
Posts: 2,318
30amp surge protector.

Whoops
__________________
2014 Stealth Evo 2850- "Woodstock"
2011 Toyota Tundra Rock Crawler TRD 5.7- "Clifford"
2013 Honda Accord Coupe V6 w/Track Pack- "Julia"

Just glad to get away
HONDAMAN174 is offline   Reply With Quote
Old 08-18-2015, 03:47 PM   #4
Senior Member
 
karrun's Avatar
 
Join Date: Jan 2015
Location: Chicago Western Burbs
Posts: 462
Didn't he install the LED readout?
__________________
2016 Roo 21SS
2005 Ford Excursion-Sherman
Mods so far:
PI hardwired EMC, Wire Shelving in wardrobe
Plexiglass screen door protector, Blue LED Wine nook
stairs, and counting...
karrun is offline   Reply With Quote
Old 08-18-2015, 06:36 PM   #5
Senior Member
 
Join Date: Apr 2013
Location: Santa Fe, Tx
Posts: 200
LED readout was an option I didn't know about. Hind sight now I'm very aware. Typical newby.
__________________
2012 F250 6.2 gasser 373 rear
2013 Rockwood 2104S Mini Lite
Ole Buzzard is offline   Reply With Quote
Old 08-19-2015, 07:38 AM   #6
Senior Member
 
karrun's Avatar
 
Join Date: Jan 2015
Location: Chicago Western Burbs
Posts: 462
I thought the hardwired PI EMC came standard with the readout. Regardless, as Honda man stated, there is a lag time (between 6-15 seconds usually) before power will cut in. If your power comes on immediately when it is plugged in, then no protection.
__________________
2016 Roo 21SS
2005 Ford Excursion-Sherman
Mods so far:
PI hardwired EMC, Wire Shelving in wardrobe
Plexiglass screen door protector, Blue LED Wine nook
stairs, and counting...
karrun is offline   Reply With Quote
Old 08-19-2015, 07:42 AM   #7
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,336
Maybe the display box is sitting on the mechanics bench with the pi unit.

TURBS
08 duramax tuned n modded
2011 32bhok Sabre
2015 camping "24 nights"
__________________
TURBS is offline   Reply With Quote
Old 08-19-2015, 07:50 AM   #8
Senior Member
 
EastlakeRoo's Avatar
 
Join Date: Aug 2009
Location: Eastlake, Ohio
Posts: 463
like others have stated there is a noticeable delay when initially plugged into shore power. If you plug in and immediately everything works then it may not be installed. Other than this delay, removing the oven enough to see if it was installed is the only other way.
__________________
2014 Wildwood 300BH
2014 Ford Explorer XLT
2011 Ford F350 FX4
Eastlake, OH
EastlakeRoo is offline   Reply With Quote
Old 08-19-2015, 07:51 AM   #9
Senior Member
 
Join Date: May 2014
Location: Shenandoah Valley, VA
Posts: 477
I think I would have a talk with the tech who installed it. Ask him how you're supposed to read the codes of what is happening when everything is out of sight. If he is an up front guy then maybe he will reinstall it, or add the remote display.
__________________
2016 Flagstaff 23LB
howie70 is offline   Reply With Quote
Old 08-19-2015, 08:10 AM   #10
Senior Member
 
Join Date: Jan 2015
Posts: 132
Not to hijack this thread but a 6 second delay? The delay on mine seems like about a minute. I can plug in the power outside, take a leisurely walk around the camper, fiddle with this, fiddle with that, go inside, take off my shoes, and then wait a bit more before the power comes on.

I'll have to actually time it - maybe it's not as long as it seems but it ain't 6 seconds.
__________________

__________________
2015 268RKS Vibe Xtreme Lite
2012 F-150 EcoSCREW Max Tow
tmhudg is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:51 PM.