Reply
 
Thread Tools Display Modes
Old 09-30-2013, 06:31 PM   #1
Junior Member
 
Join Date: Aug 2011
Posts: 19
50a surge protector vs auto leveling systems?

We have a 2011 Forest River Cedar Creek 36RE and kust got a portable TRC 34750 surge protector without LCD. Shortly after plugging in the surge protector our auto leveling system started beeping at us, showing "low voltage" and "error" messages. Does anyone have any thoughts as to why this might happen? Thanks SO much!
__________________

__________________
GRHooper is offline   Reply With Quote
Old 09-30-2013, 06:53 PM   #2
Senior Member
 
Join Date: Nov 2012
Location: X
Posts: 2,781
I would suggest that you take that back and get the Progressive Industries unit. It's Made In USA and has a lifetime warranty.

It sounds like your battery is low and that Guard has decided not to turn on the power to your RV. Do any of your 120v appliances work? Aren't there any status lights on the Guard?
__________________

__________________
BarryD0706 is offline   Reply With Quote
Old 09-30-2013, 07:11 PM   #3
Junior Member
 
Join Date: Aug 2011
Posts: 19
Thanks a lot, Barry.

Returning the surge protector is not an option, my battery is brand new, power continued to the RV, all the 120v appliances worked and there are no lights on the guard that give an indication of the problem.
__________________
GRHooper is offline   Reply With Quote
Old 09-30-2013, 07:16 PM   #4
Senior Member
 
07 ThunderRoad's Avatar
 
Join Date: Dec 2012
Posts: 167
It sounds like you have a low voltage - monitor issue. Check the voltage after the Progressive Industries unit. Is the voltage above 109 vac?
__________________
2013 Sanibel 3600 5th, 2007Dodge 2500 Cummins Turbo Diesel, 2WD, 4.10gears, Banks equipped, 18" factory rims
07 ThunderRoad is offline   Reply With Quote
Old 10-01-2013, 09:00 AM   #5
Senior Member
 
Join Date: Nov 2012
Location: X
Posts: 2,781
It might be that your converter (battery charger) is not working then. You'll need a volt meter to see what the battery voltage is when plugged in. It should be at least 13.2 volts (and normally higher).
__________________
BarryD0706 is offline   Reply With Quote
Old 10-01-2013, 09:42 AM   #6
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Quote:
Originally Posted by GRHooper View Post
Thanks a lot, Barry.

Returning the surge protector is not an option, my battery is brand new, power continued to the RV, all the 120v appliances worked and there are no lights on the guard that give an indication of the problem.
Leveler system is 12v not 120v.

Sounds like battery system has went wonky.

Buy a digital volt ohm meter for your camper your going to need it.

Doesn't matter if battery is new if the converter/charger isn't working it not charging.

Turbs
__________________
TURBS is offline   Reply With Quote
Old 10-01-2013, 11:11 AM   #7
Senior Member
 
Oakman's Avatar
 
Join Date: Jul 2007
Location: Jefferson County, MO
Posts: 5,201
Unplug from the surge protector and then plug your power cord directly into the power pedestal to see if the problem resolves itself. If it does then you probably have a defective surge protector.

Since your surge protector doesnít have the LCD display Iím guessing you purchased a used surge protector or am I wrong?
__________________

__________________


Bob and Joyce
2013 CC Silverback 29RL
2010 Ford F250 XL Crew Cab 6.4 liter diesel
ATU Local 788
Oakman is offline   Reply With Quote
Reply

Tags
leveling

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:30 AM.