Thread Tools Display Modes
Old 09-07-2014, 11:57 AM   #1
Linda and Larry Doyle
Join Date: May 2013
Location: Burlington, ON
Posts: 13
AC/Fireplace Switch not working

Hi. My AC/Fireplace switch in my 2013 Salem Villa Classic 400RETS only works now on AC side. Worked great all last year, but this year the fireplace was on but died. Works plugged into other wall plugs, but the wall plug behind the fireplace does not work. Replaced the switch and the wall plug but still no power. Any one else had this problem? Are there any wiring diagrams available? May be switch was mis-wired from factory?
Larry and Linda

2013 Salem Villa Classic
Parked at Green Acres near Kincardine, ON
400rets is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:26 AM.