Reply
 
Thread Tools Display Modes
Old 08-24-2015, 06:35 PM   #1
Member
 
Join Date: Jan 2015
Location: Mosgiel NZ
Posts: 52
All four rear tail lamps faulty

Hooked my 4wd Mitsubishi Montero/Pajero to my Coachman Apex TT then did a lights check as I do always, the back four LED tail lamps/Lights do not light up but the Number/Licence plate LEDS under the lamp units light up, no brake or indicator lights, so took the TT to auto electrician and he says all four light units are faulty, so he replaced them all and now have rear lights again, emailed the guy i bought the TT of as its still under the 12 month warranty but now he is saying I shorted the lights out by connecting the TT socket to my vehicle while the vehicle lights were on does that sound right, I did not as I always make sure my vehicle is off when connecting up the electrics, anyone had this problem where all four lamp units fail at the same time or is it possible one LED lamp shorted and took the rest out, Cheers
__________________
savi18 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:23 PM.