Reply
 
Thread Tools Display Modes
Old 03-13-2015, 10:28 AM   #1
Member
 
Join Date: Mar 2014
Posts: 30
Battery control center issues

I have a 2013 forester 3011ds the battery control center has just started clicking. I looked in side and there is a big relay with battery cables chassis and coach battery that keeps clicking. I have had no issues but not sure what it is doing it clicks about every 5 min. I do have the motor home connected to shore power all the time. I have a 30 amp camper outlet at the house and keep it connected. I can't find any information on this battery control center.

Any help would be great.


Sent from my iPad using Forest River Forums
__________________

__________________
Zoe-Woody is offline   Reply With Quote
Old 03-13-2015, 10:37 AM   #2
Site Team
 
KyDan's Avatar
 
Join Date: Mar 2008
Location: Louisville, KY
Posts: 6,715
A shot in the dark...... have you checked water in all your batteries?
Are any of them warm to the touch??
__________________

__________________
Peace!
Dan & Rita D
2004 5.3L Silverado 1500 ext. cab 2WD
1999 Suzuki Intruder Motorcycle
Blue Ox WD hitch, AirLift load levelers

Camping days 2010-53, 2011-47, 2012-41,
2013-41, 2014-31, 2015-40, 2016-44, 2017-63
KyDan is online now   Reply With Quote
Old 03-13-2015, 01:18 PM   #3
Member
 
Join Date: Mar 2014
Posts: 30
Quote:
Originally Posted by KyDan View Post
A shot in the dark...... have you checked water in all your batteries?
Are any of them warm to the touch??

Thanks for the information. I did check the batteries and they seemed fine. However, did find a lead loose on the one of the neg terminals and also a lead loose on a battery switch. When I tightened them the clicking stopped I am going to look again in a bit.

Thanks for your help it did point me to the batteries may be the problem


Sent from my iPad using Forest River Forums
__________________
Zoe-Woody is offline   Reply With Quote
Old 03-13-2015, 02:26 PM   #4
Senior Member
 
bubbles's Avatar
 
Join Date: Dec 2012
Posts: 2,555
Could it be the relay switching between charging your coach battery and chassis battery? Coach battery would have priority. Just a thought.
__________________
bubbles is offline   Reply With Quote
Old 03-13-2015, 05:18 PM   #5
Member
 
Join Date: Mar 2014
Posts: 30
Thanks for the information my loose wire didn't fix it
I checked the batteries and all three of them are fine not hot and have liquid. I think you are right it is the relay switching between coach and chassie but all batteries are fine. I have checked the voltage at the switch and it shows the voltages of the batteries. The camper starts fine and is charging fine. I took a relay out and it stopped clicking. Not sure if you can add photos to this . I have looked ont eh web and can't find anything on this battery control center
__________________
Zoe-Woody is offline   Reply With Quote
Old 03-14-2015, 01:18 PM   #6
2016 Avenger 26BH
 
Join Date: Apr 2013
Posts: 65
Is it a relay? ooorrrrr is it a circuit breaker that is overloading and resetting? Just asking. Sometimes they look very similar but have their own functions.
__________________
Cleon is offline   Reply With Quote
Old 03-14-2015, 01:47 PM   #7
Senior Member
 
bubbles's Avatar
 
Join Date: Dec 2012
Posts: 2,555
Quote:
Originally Posted by Zoe-Woody View Post
Thanks for the information my loose wire didn't fix it
I checked the batteries and all three of them are fine not hot and have liquid. I think you are right it is the relay switching between coach and chassie but all batteries are fine. I have checked the voltage at the switch and it shows the voltages of the batteries. The camper starts fine and is charging fine. I took a relay out and it stopped clicking. Not sure if you can add photos to this . I have looked ont eh web and can't find anything on this battery control center
If it is the switching between batteries this is a normal occurrence. Same thing would happen while driving with the chassis battery charging first before switching over to your coach battery. Keeps all batteries fully charged. I'm done.
__________________
bubbles is offline   Reply With Quote
Old 03-14-2015, 08:01 PM   #8
Member
 
Join Date: Mar 2014
Posts: 30
It is definitely switching to charge all batteries. However, it does it about every 5 min when not running. The batteries are no where near flat and are holding a charge very well I had them checked. There are two relays one is a small black relay with nine terminals (I removed this to make it stop). The other is a round relay which will connect the two sets of batteries together. I am thinking there is an issue with what ever monitors the chassis battery and switches. I have monitored the batteries and the veh battery has 14.3 when running but then the battery drops to 12.85 volts when the veh is turned off and the switching starts. Start the veh again and the clicking will stops. I don't think 12.85 is low and would or should bring on the relay to,charge the batteries. Having said this I am not expert and if this is normal for a motor home. I have had the relay unplugged for over 24 hrs and the clicking has stopped and the veh batteries have stayed changed and start the veh fine so no major voltage leak. Thanks for all your help and any other ideas would be great.
__________________
Zoe-Woody is offline   Reply With Quote
Old 04-27-2015, 06:47 PM   #9
Average Joe
 
MrJoe's Avatar
 
Join Date: Jul 2013
Location: Mechanicsville, MD
Posts: 689
My Sunseeker is doing the same thing. The relay/solenoid in the stairwell will switch every few seconds. It will do this for 10 minutes or so. I never noticed this before. This is happening when plugged in to shore power.


Sent from my iPhone using Forest River Forums
__________________
Joe and Karen
2014 Sunseeker 2450sf

Southern Maryland and Beyond!

MrJoe is offline   Reply With Quote
Old 05-19-2015, 12:02 PM   #10
Average Joe
 
MrJoe's Avatar
 
Join Date: Jul 2013
Location: Mechanicsville, MD
Posts: 689
Sunseeker BCC going nutz

Has anyone else experienced this issue? Mine is a Wurth BCC and the switching is almost constant while plugged in. I did a search on Wurth and couldn't find support or parts... ??
__________________

__________________
Joe and Karen
2014 Sunseeker 2450sf

Southern Maryland and Beyond!

MrJoe is offline   Reply With Quote
Reply

Tags
battery

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:58 PM.