Reply
 
Thread Tools Display Modes
Old 02-02-2014, 07:56 PM   #1
Junior Member
 
Join Date: Feb 2014
Posts: 7
Battery issue

I have a 2006 cardinal and have changed batterie so i have new one but still goes dead after couple of days any ideas?
__________________

__________________
jbroussard55 is offline   Reply With Quote
Old 02-02-2014, 08:15 PM   #2
Moderators' Assistant
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 13,282
does this happen when the trailer is plugged into shore power or when it's NOT plugged into shore power?
and does your trailer have a battery disconnect switch?

if it's not plugged in and you don't have a disconnect switch, then the trailer's normal parasitic power drains are the probable cause. especially if you have a single battery.

you'll have to keep it plugged in or get a disconnect switch installed.
__________________

__________________
Dan-Retired Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
2016 PrimeTime TracerAIR 255, pushing a 2014 Ford F150 4x4 3.5 Ecoboost w/Max Tow Package
Equalizer WDH and Prodigy BC
bikendan is offline   Reply With Quote
Old 02-02-2014, 08:24 PM   #3
Junior Member
 
Join Date: Feb 2014
Posts: 7
It happens when plugged and un plugged.I've had the rv for about a year and this just started happening.i do only have 1 batterie
__________________
jbroussard55 is offline   Reply With Quote
Old 02-02-2014, 08:25 PM   #4
Junior Member
 
Join Date: Feb 2014
Posts: 7
Also i do not see disconnect switch for batterie
__________________
jbroussard55 is offline   Reply With Quote
Old 02-02-2014, 08:51 PM   #5
Moderators' Assistant
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 13,282
then first thing would be to test the converter.
__________________
Dan-Retired Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
2016 PrimeTime TracerAIR 255, pushing a 2014 Ford F150 4x4 3.5 Ecoboost w/Max Tow Package
Equalizer WDH and Prodigy BC
bikendan is offline   Reply With Quote
Old 02-02-2014, 09:06 PM   #6
Junior Member
 
Join Date: Feb 2014
Posts: 7
How do i do that?
__________________
jbroussard55 is offline   Reply With Quote
Old 02-02-2014, 09:18 PM   #7
Junior Member
 
Join Date: Feb 2014
Posts: 7
I checked hot hot cable (red) that is connected to batterie and no juice.
__________________
jbroussard55 is offline   Reply With Quote
Old 02-02-2014, 10:26 PM   #8
Senior Member
 
sherdep's Avatar
 
Join Date: Jan 2011
Location: Saint Cloud FL
Posts: 1,565
sounds like you may have a bad fuse in the load center

verify your fuses are good
or
there should be a automatic resettable fuse block somewhere close to the battery - may have to trace the hot (red) from the battery back to along the frame and check it on the block
__________________
2011 Rockwood Mini Lite 2306 - Matt
2004 Dodge Ram 1500 Qaud Cab 4x4 with 35" tires and 3.92 gears, Dynatech Longtube Headers & Fabtech 6" lift + Superchips with shift Tuning
Nights Camped 2011 (37) - 2012 (16)-2013 (2) -2014 (5) -2015(0)
USMC 91 - 95 - F/A-18 Aviation Ordnance
sherdep is offline   Reply With Quote
Old 02-03-2014, 10:45 AM   #9
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,169
There are two resettable current limiters between the converter and the battery "red" cable.

Look within 18 inches of the battery for one, and somewhere on the frame (or under the pin box on a 5th wheel) for the other.

Check for corrosion and a popped reset button on the side.
Attached Thumbnails
Click image for larger version

Name:	360426586.jpg
Views:	65
Size:	30.1 KB
ID:	45755   Click image for larger version

Name:	Camper Photos 003.jpg
Views:	69
Size:	50.4 KB
ID:	45757   Click image for larger version

Name:	SAM_3972.jpg
Views:	82
Size:	44.5 KB
ID:	45758  
Attached Images
    
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 02-03-2014, 11:21 AM   #10
Senior Member
 
Join Date: Jan 2014
Location: West Carrollton, Ohio
Posts: 473
I had this problem a few years ago and it was my converter. It happened while on vacatin. I now carry a spare.
__________________

__________________
OKI Marine is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:40 AM.