Reply
 
Thread Tools Display Modes
Old 05-18-2015, 02:03 PM   #1
Senior Member
 
Maris's Avatar
 
Join Date: Jun 2013
Posts: 150
Battery not holding charge in new 2016TT

I know our new 2016 Rockwood 2604 is under warranty but I'm wondering if there is a simple fix. All is well when plugged into shore power but nothing works when unplugged. We plugged the TT back in for 24 hours & when unplugged there is not enough battery to even light the panel. We have done that twice now. My DH removed the battery & found the battery cables & terminals severely corroded. The trailer came from the manufacturer (Indiana?) to our dealer in Ontario and sat at the dealer for a few weeks until we brought it home. We dry camped a number of times in our Shamrock & only needed to use the generator after a few days. The battery looks new but the label on top did not have the dates punched in.

Maris & Ken


Sent from my iPad using Forest River Forums

Maris
2010 Shamrock 23SS (sold)
2015 Rockwood 2604WS - almost here
2008 Dodge Ram 1500 5.7 hemi
__________________

__________________
Maris is offline   Reply With Quote
Old 05-18-2015, 03:32 PM   #2
Moderators' Assistant
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 13,295
Remember, the battery is installed by the dealer, not the factory.
__________________

__________________
Dan-Retired Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
2016 PrimeTime TracerAIR 255, pushing a 2014 Ford F150 4x4 3.5 Ecoboost w/Max Tow Package
Equalizer WDH and Prodigy BC
bikendan is offline   Reply With Quote
Old 05-18-2015, 03:40 PM   #3
Senior Member
 
Maris's Avatar
 
Join Date: Jun 2013
Posts: 150
Thanks Bikendan! I did not know that. We have the trailer plugged back in after cleaning the terminals & cables. If it still doesn't take a charge the we will try it on our battery charger. I guess we will have to call our dealer tomorrow. Hopefully it's the battery and not the converter.
__________________
Maris is offline   Reply With Quote
Old 05-18-2015, 03:45 PM   #4
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
There's a circuit breaker tripped.
Follow the positive battery cable and you should find it.
It has a little black button to reset it.

Also, do you have the battery disconnect switch in the right position?


TURBS
08 duramax tuned n modded, 32bhok Sabre
2015 camping "6 nights"
__________________
TURBS is offline   Reply With Quote
Old 05-18-2015, 03:46 PM   #5
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Looks like this.


Name:   uploadfromtaptalk1431978398253.jpg
Views: 157
Size:  11.2 KB

TURBS
08 duramax tuned n modded, 32bhok Sabre
2015 camping "6 nights"
__________________
TURBS is offline   Reply With Quote
Old 05-18-2015, 04:21 PM   #6
Senior Member
 
Maris's Avatar
 
Join Date: Jun 2013
Posts: 150
Thanks Turbs. Went out before seeing your pic. The battery disconnect is in the right position. Went back out & saw that little button. It's sticking out about 1/8". Could pressing it if it doesn't need it cause a problem. Sure love this forum. Mosquitoes are brutal here so we have to work quickly.
__________________
Maris is offline   Reply With Quote
Old 05-18-2015, 06:09 PM   #7
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Press away my friend!

TURBS
08 duramax tuned n modded, 32bhok Sabre
2015 camping "6 nights"
__________________
TURBS is offline   Reply With Quote
Old 05-18-2015, 06:19 PM   #8
Site Team
 
Flybob's Avatar
 
Join Date: Oct 2014
Posts: 5,570
Check the 40A fuses in the convertor. If they are blown, it will not charge.
__________________

2015 Freedom Express 248RBS
TV 2015 Silverado HD2500 Duramax
TST Tire Monitors
Honda 2000I + Companion
2 100W solar panels
Flybob is offline   Reply With Quote
Old 05-18-2015, 06:27 PM   #9
Senior Member
 
Maris's Avatar
 
Join Date: Jun 2013
Posts: 150
Hi Turbs. We pushed the button & now the battery is recharging. Why would we need to reset or is it possible that it was disengaged when we brought the trailer home? Should we be concerned? Thanks again for your excellent advice.

Maris & Ken


Sent from my iPad using Forest River Forums

Maris & Ken & Happy yellow lab campers,
Dexter & Stella
2016 Rockwood 2604WS
2008 Dodge Ram 1500 5.7 hemi
__________________
Maris is offline   Reply With Quote
Old 05-18-2015, 06:34 PM   #10
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Quote:
Originally Posted by Maris View Post
Hi Turbs. We pushed the button & now the battery is recharging. Why would we need to reset or is it possible that it was disengaged when we brought the trailer home? Should we be concerned? Thanks again for your excellent advice.

Maris & Ken


Sent from my iPad using Forest River Forums

Maris & Ken & Happy yellow lab campers,
Dexter & Stella
2016 Rockwood 2604WS
2008 Dodge Ram 1500 5.7 hemi
It just tripped, it sometimes just happens under high load.

Happy camping!

TURBS
08 duramax tuned n modded, 32bhok Sabre
2015 camping "6 nights"
__________________

__________________
TURBS is offline   Reply With Quote
Reply

Tags
battery

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:10 PM.