Reply
 
Thread Tools Display Modes
Old 06-05-2013, 04:10 PM   #11
Senior Member
 
Join Date: Jan 2011
Posts: 326
With battery hooked up and lights on (dim) try hooking up another ground wire from battery to a good contact on the trailer frame. If your lights brighten yo then know you have a bad ground.


C.B.
__________________

__________________
cbvp is offline   Reply With Quote
Old 06-05-2013, 04:14 PM   #12
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
My thinking assuming the new battery is fully charged .
the ground wire connection is bad.
Ok cleaned now.
The internal resistance is very high in ground wire.
Replace ground wire if so.
The positive lead circuit breaker is so corroded that its limiting current as amps go up voltage goes down.
Replace circuit breaker.
There's a loose connection in wiring box under hitch or camper.
Fix and repair loose connection.


Turbs
__________________

__________________
TURBS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:45 AM.