Reply
 
Thread Tools Display Modes
Old 03-28-2015, 09:38 AM   #1
Junior Member
 
obxbronco's Avatar
 
Join Date: Mar 2015
Posts: 17
Battery Question

I have an 07 roo 19(new to me) I bought a new battery for it, when I hook cables up nothing happens, no lights. I'm a newbie so bear with me lol. Is the something I'm sopposed to be doing, flipping a switch or something?


Sent from my iPhone using Tapatalk
__________________

__________________
obxbronco is offline   Reply With Quote
Old 03-28-2015, 09:45 AM   #2
Senior Member
 
bubbles's Avatar
 
Join Date: Dec 2012
Posts: 2,562
Do you have a battery disconnect switch (for storage) that needs to be reset ?
__________________

__________________
bubbles is offline   Reply With Quote
Old 03-28-2015, 09:47 AM   #3
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 3,237
First have to make sure battery is connected properly. The negative from the battery would go to the cable that is hook up directly to trailer frame. Other lead to positive obviously. If still no power, check underneath trailer near tongue for a mini-breaker and press small black button to re-set if you have. See picture. Also if battery was connected with reverse leads, the converter reverse fuses might be blown. (2 red 40 amps fuses shown in DC panel). Remember not all trailer are the same, these are suggestions.
Attached Thumbnails
Click image for larger version

Name:	mini-breaker pic.jpg
Views:	129
Size:	30.1 KB
ID:	72339   Click image for larger version

Name:	Breaker Box.jpg
Views:	116
Size:	59.1 KB
ID:	72341  
Attached Images
 
__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2008 F250 Lariat CC SB 6.8L V10 4.10 axle ratio (NITTO TERRA GRAPLER G2 LT275/65R20E)
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2011(21) 2012(36) 2013 (17) 2014 (18) 2015 (18) 2016 (36) 2017 (32)
fonzie is offline   Reply With Quote
Old 03-28-2015, 09:49 AM   #4
Moderator Emeritus
 
Dave_Monica's Avatar
 
Join Date: Sep 2007
Location: Ontario, Canada
Posts: 4,329
Follow the power lead from the battery and look for a junction box near the tongue of the camper...should be a in-line 30A fuse or resettable circuit breaker that may need replacing/resetting.

Dave


Edit: Ha...Fonzie beat me out
__________________


Nights camped in 2013 - 55, 2014 - 105, 2015 - 63
Dave_Monica is offline   Reply With Quote
Old 03-28-2015, 09:51 AM   #5
Junior Member
 
obxbronco's Avatar
 
Join Date: Mar 2015
Posts: 17
Thanks I'll check those when I get off work. I know the leads are hooked to right spot.


Sent from my iPhone using Tapatalk
__________________
obxbronco is offline   Reply With Quote
Old 03-28-2015, 08:57 PM   #6
Junior Member
 
obxbronco's Avatar
 
Join Date: Mar 2015
Posts: 17
Quote:
Originally Posted by fonzie View Post
First have to make sure battery is connected properly. The negative from the battery would go to the cable that is hook up directly to trailer frame. Other lead to positive obviously. If still no power, check underneath trailer near tongue for a mini-breaker and press small black button to re-set if you have. See picture. Also if battery was connected with reverse leads, the converter reverse fuses might be blown. (2 red 40 amps fuses shown in DC panel). Remember not all trailer are the same, these are suggestions.
I have the mini breaker, but can't see a reset, also I don't have a fuse coming off of it.
__________________
obxbronco is offline   Reply With Quote
Old 03-28-2015, 09:08 PM   #7
Member
 
jkeezer's Avatar
 
Join Date: Jan 2015
Location: East Taunton, MA
Posts: 62
If there is no reset button , it is like a fuse and has most likely"popped"/ gone bad as it is out in the weather. There is no fuse coming out of it. You should be able to use a continuity tester to see if it is good.
__________________
2015 Cedar Creek 38CK
jkeezer is offline   Reply With Quote
Old 03-28-2015, 09:16 PM   #8
Junior Member
 
obxbronco's Avatar
 
Join Date: Mar 2015
Posts: 17
Quote:
Originally Posted by bubbles View Post
Do you have a battery disconnect switch (for storage) that needs to be reset ?
I have no clue
__________________
obxbronco is offline   Reply With Quote
Old 03-28-2015, 09:28 PM   #9
Moderator Emeritus
 
Dave_Monica's Avatar
 
Join Date: Sep 2007
Location: Ontario, Canada
Posts: 4,329
Quote:
Originally Posted by obxbronco View Post
I have the mini breaker, but can't see a reset, also I don't have a fuse coming off of it.
Does it have a small black reset button as shown in the last photo that Fonzie posted?

Dave
__________________


Nights camped in 2013 - 55, 2014 - 105, 2015 - 63
Dave_Monica is offline   Reply With Quote
Old 03-28-2015, 10:06 PM   #10
Junior Member
 
obxbronco's Avatar
 
Join Date: Mar 2015
Posts: 17
I got it guys, finally found the reset, and all works. Thank u guys very much!!!
__________________

__________________
obxbronco is offline   Reply With Quote
Reply

Tags
battery

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:11 AM.