Thread Tools Display Modes
Old 09-16-2014, 05:15 PM   #1
Junior Member
Join Date: Jul 2014
Posts: 8
Brake sensor/jack deployment

It's a couple of weeks before our bug trip and I thought I would take my RV have this fixed: my jacks will not deploy unless the parking brake is on. Problem is, I have to set the brake many times for the sensor to acknowledge that the brake is set. When I dropped it off today the mechanic said "well, we'll look at it but they all do that." Should I have just driven it back off of their lot and took it home to look for another mechanic? Does anyone else have this problem? I have a 2004 34' Georgetown.
Travelbug49 is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:18 AM.