Reply
 
Thread Tools Display Modes
Old 10-12-2015, 12:41 PM   #1
Member
 
Join Date: May 2012
Posts: 45
Ceiling Lighting Problem - 2011 Berkshire 390RB

The darned lights won't come on. Tested the circuit to the switch and have power. The lights light when I bypass the switch. So, I think, it's the switch. To double-check, I exchange the bedroom switch w/the living room switch. The LR switch works fine in the bedroom, but the bedroom switch won't work the lights in the LR. To further confound me, we had the same problem last year, but the lights started working again after we decided (but before we received) dealer assistance. Any thoughts on possible course of action?
__________________

__________________
helferdm is offline   Reply With Quote
Old 10-12-2015, 12:46 PM   #2
Senior Member
 
Ddubya's Avatar
 
Join Date: Aug 2012
Location: Sherman Texas
Posts: 262
Pull the fixture down and pull the wires from the ceiling far enough to see the wiring connections. You may have a bad wire nut connection.
I had this happen last year.
__________________

__________________
Ddubya is offline   Reply With Quote
Old 10-12-2015, 12:49 PM   #3
Member
 
Join Date: May 2012
Posts: 45
Sounds logical. Any light or is there a first one in the chain?
__________________
helferdm is offline   Reply With Quote
Old 10-12-2015, 12:52 PM   #4
Senior Member
 
Ddubya's Avatar
 
Join Date: Aug 2012
Location: Sherman Texas
Posts: 262
I would start with the closest one to the switch. They are wired in series but you never know which one is the first.
__________________
Ddubya is offline   Reply With Quote
Old 10-12-2015, 03:53 PM   #5
Member
 
Join Date: May 2012
Posts: 45
No joy, I'm afraid. Two wires coming in, split to a light on the right and to the one on the left. Nothing. They get power with the switch out of the circuit, so it doesn't seem like it's the series after the switch. Maybe a poor ground?
__________________
helferdm is offline   Reply With Quote
Old 10-12-2015, 04:50 PM   #6
Senior Member
 
Ddubya's Avatar
 
Join Date: Aug 2012
Location: Sherman Texas
Posts: 262
Ok, the lights are 12volts DC so there are only two wires. I would check at the first light to see if you have voltage coming from the switch.. I think you said that there was voltage at the switch.
It could still be a bad or corroded connection. They use the little crimp connectors which if not properly crimped can arc and create a bad connection. Wiggle the connections, sometimes that will indicate the bad crimp.


Sent from my iPad using Forest River Forums
__________________

__________________
Ddubya is offline   Reply With Quote
Reply

Tags
2011, berkshire, ceiling light

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:31 PM.