Reply
 
Thread Tools Display Modes
Old 09-28-2015, 03:18 PM   #11
Senior Member
 
Tom48's Avatar
 
Join Date: Apr 2015
Location: Ontario, California
Posts: 1,007
Quote:
Originally Posted by TGR View Post
I would ensure that it isn't the batteries that are causing the converter to shut down. Check them with a volt meter or at least see if they are low on water when no AC power is supplied to your rig.
Check the batteries. Then check the maintenance charge rate from the converter charger. You may also look at the light load because if you're in this thing a lot because if you're in this thing a lot and have all the lights on that alone can be a pretty good load on the battery and charger. Never too late to go to the LEDs
__________________

__________________
Tom48 is offline   Reply With Quote
Old 09-28-2015, 03:20 PM   #12
Senior Member
 
PhoneDude 8289's Avatar
 
Join Date: Sep 2013
Location: Texas
Posts: 1,089
Quote:
Originally Posted by tjerrard View Post
Camping last week, on last evening, with 30amp electric plugged in routed through protector that does it all, surge, hi/low voltage, neutral ground sensing etc. Had DC lights flickering & radio (on DC circuit) cutting in/out. Looked at circuit panel but nothing obvious so pushed dc fuses, water pump fuse a little out of place so removed looked at it and put it back in.

Checked pump but it did not work. Also found that other items had ceased working on the convenience panel. Went back to DC side of circuit panel pulled/put back in fuses. Things worked again. So left everything alone knowing more had to be done at home. This was the last night returned home next day.

At home removed external AC electric. Turned battery isolation switch to off. Ensured no power to AC or DC circuits. Removed cover from the circuit panel and started checking the wiring. All grounds and wiring from converter and battery were good.

What I found was the water pump power wire at the terminal, by the fuse, was almost completely burned through, hanging by a couple of strands. Removed the wire, trimmed the burned end, cleaned the terminal, pulled the fuse and replaced it with a new one and reattached the wire, checked all other terminal connections which were solid.

Put everything back together, applied all power and tested the systems. All now appears to be OK.

Just a heads up that if you are having power problems you might want to check the wiring on the fuse/circuit breaker terminals.
One of the first things I did after taking delivery on our RV was to open up the power panel and check all terminals for tightness. There were a few that I got at least a 1/2 turn on the terminal screw. In the last almost two years I have checked all the outlets in the RV, all are good, no trouble found.
__________________

__________________
Joe & Beverly
2014 Ram CTD, CC, SB
2014 8289WS lifted
PhoneDude 8289 is offline   Reply With Quote
Old 09-28-2015, 03:29 PM   #13
Member
 
Join Date: Jan 2011
Location: Nova Scotia
Posts: 61
Just purchased the PD9260 with charge wizard in July from BestConverter - Converters, Inverters, Electrical Supplies, Electronics for $177.00 and $50.50 shipping ( US Funds ). With HST added came to $350.00 Canadian and had it in about a week. Very happy with their service.
__________________
riversedge is offline   Reply With Quote
Old 09-28-2015, 03:37 PM   #14
Senior Member
 
chideock's Avatar
 
Join Date: Jul 2014
Posts: 144
Quote:
Originally Posted by riversedge View Post
Just purchased the PD9260 with charge wizard in July from BestConverter - Converters, Inverters, Electrical Supplies, Electronics for $177.00 and $50.50 shipping ( US Funds ). With HST added came to $350.00 Canadian and had it in about a week. Very happy with their service.

Thanks will look at them.

Tom
__________________
2016 Sunseeker 3010ds towing a 2013 Ford Explorer 3.5L AWD.
chideock is offline   Reply With Quote
Old 09-28-2015, 03:42 PM   #15
Senior Member
 
chideock's Avatar
 
Join Date: Jul 2014
Posts: 144
Quote:
Originally Posted by TGR View Post
I would ensure that it isn't the batteries that are causing the converter to shut down. Check them with a volt meter or at least see if they are low on water when no AC power is supplied to your rig.

I think the batteries may be at issue. Bought this unit used last year with these batteries, interstate. Have no idea if they are OEM or replacement nor how old they are let alone if they were maintained.

Frankly I have no idea about batteries or how to test them. Just know they are now sitting in my basement and the MH is in winter storage.

Tom
__________________
2016 Sunseeker 3010ds towing a 2013 Ford Explorer 3.5L AWD.
chideock is offline   Reply With Quote
Old 09-28-2015, 03:45 PM   #16
Senior Member
 
chideock's Avatar
 
Join Date: Jul 2014
Posts: 144
Quote:
Originally Posted by Herk7769 View Post
Extremely low battery voltage is not the only failure mode that will prevent your converter from starting. A shorted cell will also prevent the converter from turning on.

If the other cells are OK, the voltage will appear low but chargeable, yet the battery will fail a load test. The converter will "see" the shorted cell and not turn on to save itself from the inevitable overload.

Thanks, see my post above about my batteries. I think I will start with them before a new converter.

I wonder if the old converter tried on the new batteries will, if the converter is bad as well, hurt the new batteries.

Tom
__________________
2016 Sunseeker 3010ds towing a 2013 Ford Explorer 3.5L AWD.
chideock is offline   Reply With Quote
Old 09-28-2015, 03:47 PM   #17
Senior Member
 
chideock's Avatar
 
Join Date: Jul 2014
Posts: 144
Quote:
Originally Posted by PhoneDude 8289 View Post
One of the first things I did after taking delivery on our RV was to open up the power panel and check all terminals for tightness. There were a few that I got at least a 1/2 turn on the terminal screw. In the last almost two years I have checked all the outlets in the RV, all are good, no trouble found.

Great advice, thanks

Tom
__________________
2016 Sunseeker 3010ds towing a 2013 Ford Explorer 3.5L AWD.
chideock is offline   Reply With Quote
Old 09-28-2015, 03:48 PM   #18
Senior Member
 
chideock's Avatar
 
Join Date: Jul 2014
Posts: 144
Quote:
Originally Posted by Tom48 View Post
Check the batteries. Then check the maintenance charge rate from the converter charger. You may also look at the light load because if you're in this thing a lot because if you're in this thing a lot and have all the lights on that alone can be a pretty good load on the battery and charger. Never too late to go to the LEDs

I guess this is the reason I needed to change to LEDs

Tom
__________________
2016 Sunseeker 3010ds towing a 2013 Ford Explorer 3.5L AWD.
chideock is offline   Reply With Quote
Old 09-29-2015, 05:54 PM   #19
2012 FR Lexington 283TS
 
Join Date: Apr 2014
Location: Ogden, Utah
Posts: 15
Progressive Dynamics Power Converters

I installed the PD9200 after taking the MH in three times because the batteries would not charge or would not charge fully. The service techs (it was always someone new) would check the WFCO unit and say that it was working fine. I replaced a set of batteries because the tech said I probably had a bad cell. After installing the PD9200, I have not had any problems. There is not clicking sounds and the lights don't go dim and then bright any more. When I checked the WFCO unit after removing it, I noticed that the two fuses were 35 amps, the unit had a 55 amp rating. Also one of the fuses was burnt (this was almost impossible to see when it was installed). I am now going to install the Transfer Switch from Progressive (PD5110610) because I do not trust the WFCO brand. I would replace the WFCO power center but it would require more time than I currently have. Maybe during the winter. Installing the power converter took less than 30 minutes. This was only because I had to remove the plywood cover under the bed before starting and couldn't find a square bit for the screws. It is that simple to install. Good Luck.
__________________
CaboSnow is offline   Reply With Quote
Old 09-29-2015, 07:30 PM   #20
Senior Member
 
chideock's Avatar
 
Join Date: Jul 2014
Posts: 144
CaboSnow - Thanks for you insight.

Took the batteries into the shop yesterday, they called late today and said they are in great shape no problems.

So a new converter goes in the MH in the spring. Forest River really wedged the WFCO into a space below the bed and there is extremely limited space in the rest of the area due to water tank, plumbing, pump, transfer switch etc. It even looks like the converter was put in first and then the water tank as the tank looks like it overlaps one edge of the converter where a fastener may be!!!! If I'm lucky a fastener wasn't used on that edge.

I'll repost next spring when the work is done.

Thanks all.

Tom
__________________

__________________
2016 Sunseeker 3010ds towing a 2013 Ford Explorer 3.5L AWD.
chideock is offline   Reply With Quote
Reply

Tags
converter

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:48 PM.