Reply
 
Thread Tools Display Modes
Old 05-30-2017, 09:24 PM   #11
Senior Member
 
Join Date: May 2013
Posts: 361
Check for bad connections.
Also: confirm your NOT running your refrig on DC
Did you try to connect converter directly to battery? This would eliminate camper systems as fault= troubleshooting.
__________________

mfMcFroggierPod is offline   Reply With Quote
Old 05-31-2017, 07:58 PM   #12
Junior Member
 
srcpaid's Avatar
 
Join Date: Apr 2017
Posts: 3
No loose connectors, not running frig on 12v, and converter output terminals showed 0 volts output. Each tech confirmed the converters were dead, both in field and at dealer.
__________________

srcpaid is offline   Reply With Quote
Old 06-01-2017, 05:34 AM   #13
Senior Member
 
Join Date: May 2013
Posts: 361
Has the 120v A/C feed circuit been tested for faults to the converter?
__________________

mfMcFroggierPod is offline   Reply With Quote
Reply

Tags
converter

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by


Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:10 AM.