Reply
 
Thread Tools Display Modes
Old 12-01-2012, 10:09 AM   #1
Junior Member
 
Join Date: Nov 2012
Posts: 25
converter problem

Hello everyone , this is my first post. This is also my first 5th wheel. We bought a 2010 Cardinal 3625 . When we went to pick it up they were changing out the converter , since weve been in it the past two months the battery does not hold a charge and the lights flicker. I just turned off the battery disconect while I was writing this and the gas alarm started going off. We love the camper , guess we have alot to learn. I found a piece of paper that has parallax on it in all our paper work. the converter in it is a INTEL-POWER 9200 series 60 amp converter / charger . ADVICE NEEDED
__________________

__________________
cjoel is offline   Reply With Quote
Old 12-01-2012, 10:52 AM   #2
rce
Senior Member
 
Join Date: Jul 2012
Location: Canada
Posts: 120
Quote:
Originally Posted by cjoel View Post
Hello everyone , this is my first post. This is also my first 5th wheel. We bought a 2010 Cardinal 3625 . When we went to pick it up they were changing out the converter , since weve been in it the past two months the battery does not hold a charge and the lights flicker. I just turned off the battery disconect while I was writing this and the gas alarm started going off. We love the camper , guess we have alot to learn. I found a piece of paper that has parallax on it in all our paper work. the converter in it is a INTEL-POWER 9200 series 60 amp converter / charger . ADVICE NEEDED
I'm no expert whatsoever and like you, new to my trailer and this forum. I had a sort of similar problem. Took my new to me TT in to get WD hitch installed. When I unplugged from house power propane alarm went off. If I turned outside light on (or off?) alarm stopped. Discovered later + battery cable was corroded right off the terminal & making sporadic contact at best. I also had been wondering why my 12 volt lighting wasn't working properly! Battery was toast too.

Anyway a wild guess is that the propane alarm sounds if it has no power source. Maybe has an internal rechargable battery to do so???

So I'm wondering if you have a bad battery and/or when you did the battery disconnect thing the alarm going off is normal? When you think of it that would be a very useful feature as if it loses all power and you don't know it and you have a gas leak that's bad!

With you I will wait for the real experts to answer your question.
__________________

__________________
rce is offline   Reply With Quote
Old 12-01-2012, 11:25 AM   #3
Junior Member
 
Join Date: Nov 2012
Posts: 25
I just looked up a new Cardinal 3675 and it comes with a 70 amp converter, my 2010 3625 has only a 60 amp could this be the wrong converter .
__________________
cjoel is offline   Reply With Quote
Old 12-01-2012, 11:53 AM   #4
Phat Phrog Stunt Team
 
AquaMan's Avatar
 
Join Date: Apr 2012
Location: Tipp City, OH
Posts: 6,477
Quote:
Originally Posted by cjoel View Post
I just looked up a new Cardinal 3675 and it comes with a 70 amp converter, my 2010 3625 has only a 60 amp could this be the wrong converter .
This could be the right converter for your model. Newer models are always adding more electronics, thus the need for more power.
__________________
2016 Georgetown 364TS
Nights Camped 2017 - 49
AquaMan is online now   Reply With Quote
Old 12-01-2012, 12:23 PM   #5
Moderator Emeritus
 
Dave_Monica's Avatar
 
Join Date: Sep 2007
Location: Ontario, Canada
Posts: 4,329
As the camper had a faulty converter that had to be replaced, the battery has most likely been fully discharged in the past and is incapable of holding a charge. You could take it to a auto parts store and have it load-tested.

If the battery has already been replaced you need to check the voltage that the converter outputs. With some 12V lights/apps in use, the converter should be putting out at least 13.5V, which can be measured across the battery terminals. With the shorepower unplugged, a fully charged battery should measure around 12.7V.

Dave
__________________


Nights camped in 2013 - 55, 2014 - 105, 2015 - 63
Dave_Monica is offline   Reply With Quote
Old 12-04-2012, 08:51 PM   #6
Junior Member
 
Join Date: Nov 2012
Posts: 25
Im learning , it was a bad battery.
__________________

__________________
cjoel is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:09 PM.