Reply
 
Thread Tools Display Modes
Old 05-08-2015, 01:46 PM   #1
Member
 
Join Date: Nov 2010
Posts: 80
Electrical Problem

I have a 2011 Rockwood fifth wheel which has been very fool proof until now. When we are not traveling I keep the fifth wheel in the shed and plugged in. We used it about three weeks ago and every thing was fine. Now we have 110 power at the outlets and to the microwave, but the lights and slides will not work. I expect that my converter may be the problem, but I am not experienced at electrical problems. How can I pin down the problem? Is it common for these converters to fail? The converter model # is WF-8955PEC. If that is the problem, where might I look to purchase one? Any help would be greatly appreciated.
__________________

__________________
Michigan-traveler is offline   Reply With Quote
Old 05-08-2015, 05:01 PM   #2
Senior Member
 
Timex's Avatar
 
Join Date: Jun 2011
Location: Hattiesburg, MS
Posts: 1,658
IF, it's the converter, try this site. BestConverter - Converters, Inverters, Electrical Supplies, Electronics
__________________
2012 Flagstaff V Lite 30 WRLTS
2005 Dodge Ram 2500 5.7 Mag Hemi 3.72 Rearaxle
Nights camped 2015 = 23
Nights camped 2016 = 25
Nights camped 2017 = 13
Timex is offline   Reply With Quote
Reply

Tags
electric, electrical

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:42 AM.