Reply
 
Thread Tools Display Modes
Old 04-01-2015, 11:12 AM   #1
Junior Member
 
Join Date: Apr 2015
Posts: 8
Flaky 12v service

I have a 2012 Puma Palomino TT and have an issue with 12v electrical. Upon opening up the unit the slideouts opened normally and the weather was cold around 35 degrees or so. Last weekend, 2-weeks after opening the unit, I turned on a light switch and the low voltage beeping came on, the light was dim and so were all the other lights. It was like being in a brown out condition at the extreme. This is all while hooked up to shore power and the battery in place. I tried it with battery removed and still on shore power and condition was sameÖdim so it isnít a bad battery correct? 12v battery isnít necessary to run 12v devices as long as Im on shore power correct? Shore power and battery in place is how it has been throughout winter as Iím at a seasonal campground. Yesterday I returned with a multimeter to check voltages but for grins, first thing I did was flip a light switch. The light was bright. I continued throughout the TT and all lights worked, bathroom fan and microwave worked, all 12v devices worked normally. My question is: Why low current to 12v 3 days ago and then normal now? Converter issue? Battery?

Thanks in advance!

Jeff
__________________

__________________
sky5900 is offline   Reply With Quote
Old 04-01-2015, 11:15 AM   #2
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Converter may be on its way out.


TURBS
08 duramax tuned n modded, 32bhok Sabre
__________________

__________________
TURBS is offline   Reply With Quote
Old 04-01-2015, 11:18 AM   #3
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Turn on all the 12v items you can, you should hear the fan running in the converter.
If not the fan "common issue" is junk and the converter is over heating.
I'm assuming a wfco converter?

TURBS
08 duramax tuned n modded, 32bhok Sabre
__________________
TURBS is offline   Reply With Quote
Old 04-01-2015, 11:21 AM   #4
Senior Member
 
bubbles's Avatar
 
Join Date: Dec 2012
Posts: 2,562
You said you tried only the 12 volt items the first time around. Could your shore power connection have been at fault for awhile and was ok when you returned?
__________________
bubbles is offline   Reply With Quote
Old 04-01-2015, 11:26 AM   #5
Junior Member
 
Join Date: Apr 2015
Posts: 8
Will do thanks! Parallax Converter.
__________________
sky5900 is offline   Reply With Quote
Old 04-01-2015, 11:28 AM   #6
Junior Member
 
Join Date: Apr 2015
Posts: 8
Electrician checked the service box at shore and was normal. Isolated to the RV.
__________________
sky5900 is offline   Reply With Quote
Old 04-01-2015, 11:29 AM   #7
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
I've not had to much contact with a parallax but sounds like a similar situation.

TURBS
08 duramax tuned n modded, 32bhok Sabre
__________________
TURBS is offline   Reply With Quote
Old 04-01-2015, 11:34 AM   #8
Junior Member
 
Join Date: Apr 2015
Posts: 8
An RV technician is coming out tomorrow night with a converter replacement. Am just trying to avoid what will end up a $500 bill if something is readily evident. If the fan is shot, then I should have him bring just a fan as well. This way the fan just gets replaced, solving what may be just a normal thermal cut-off. Sound logical?
__________________
sky5900 is offline   Reply With Quote
Old 04-01-2015, 12:35 PM   #9
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
I believe parallax has a pretty good trouble shooting guide on there website.

TURBS
08 duramax tuned n modded, 32bhok Sabre
__________________
TURBS is offline   Reply With Quote
Old 04-01-2015, 04:24 PM   #10
Junior Member
 
Join Date: Apr 2015
Posts: 8
Came out this afternoon and 12v was fine so I turned on almost all lights, fridge and bathroom fan. After 5 minutes, everything dimmed and low power alarm sounded. During this time, the converter fan did not come on. Look like a cooling fan failure? If so, replace just fan or whole converter?
__________________

__________________
sky5900 is offline   Reply With Quote
Reply

Tags
service

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:33 PM.