Reply
 
Thread Tools Display Modes
Old 08-02-2015, 04:13 PM   #1
Junior Member
 
Join Date: Jul 2015
Posts: 11
Front led dome lights and king jack antenna no power

I have a brand new 364ts. We stayed in it overnight for the first time. Woke up this morning and all three front overhead dome lights don't work and there is no power to the king jack air antenna. All four fixtures are in a row down the midline of the Rv from just in front of the bath to just before the front overhead bunk. Everything else works. I checked fuses in fuse box above rear bed and all fuses were good. Any ideas?
__________________

__________________
cousin eddie johnson is offline   Reply With Quote
Old 03-26-2016, 10:17 AM   #2
Senior Member
 
SternHappens's Avatar
 
Join Date: Feb 2015
Location: Seymour, TN
Posts: 202
We are set up in our 364TS and have been watching TV for 2 days, all of a sudden TV pictures freezes, change channel no signal, look up and no power on the King Jack antenna (had just been working fine) checked fuses over bed, nothing blown, everything else seems to be working, lights in kitchen, etc. Any idea where the fuse for the king jack is hiding?
__________________

__________________
2015 Georgetown 364TS, '05 TJ flat, or '14 Fiesta 5 spd w/Tandem Tow Dolly HDXL 8x10, & EZGO Customized Cart
Days Out '17-25{Days in Shop 141}; '16-59; '15-56.
2011 Flagstaff V-Lite 30WFKS '14-24, '13-33, '12-36, '11-29, '10-23.

SternHappens is offline   Reply With Quote
Old 03-26-2016, 12:54 PM   #3
Senior Member
 
Join Date: Dec 2010
Location: East Berlin
Posts: 339
The king jack power injector has a self resetting fuse, it should reset after cooling. If it does not might have had the power injector go bad.
__________________
Rich5117 is offline   Reply With Quote
Old 03-26-2016, 03:32 PM   #4
Senior Member
 
SternHappens's Avatar
 
Join Date: Feb 2015
Location: Seymour, TN
Posts: 202
after flipping switch on and off a few times and tapping cases, I went to juggle the antenna, as soon as I push the button in and slightly moved it it came right on. So either that was coincidentally as the fuse reset or I have a loose connection in there somewhere. If it happens again, guess I open it up and take a look.
__________________
2015 Georgetown 364TS, '05 TJ flat, or '14 Fiesta 5 spd w/Tandem Tow Dolly HDXL 8x10, & EZGO Customized Cart
Days Out '17-25{Days in Shop 141}; '16-59; '15-56.
2011 Flagstaff V-Lite 30WFKS '14-24, '13-33, '12-36, '11-29, '10-23.

SternHappens is offline   Reply With Quote
Old 03-26-2016, 04:34 PM   #5
Senior Member
 
Join Date: Dec 2010
Location: East Berlin
Posts: 339
Sternhappens I would still take off the cover and check the connections if your fuse got hot and tripped it may be a bad connection, at least it gives you some place to start
__________________
Rich5117 is offline   Reply With Quote
Reply

Tags
antenna, led, light, power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:28 AM.