Thread Tools Display Modes
Old 07-06-2014, 06:37 PM   #1
Join Date: Mar 2014
Posts: 98
Generator Problem

I was recently on a 2 week trip out west and had a problem with my generator when we headed into las vegas. It was very hot (104) and we were left Vegas and headed North and of course started generator and AC before we left the parking lot. Very soon after the generator was running but it was not producing electricity. I opened the outside compartment and noticed the breaker on the generator was tripped. I reset the breaker only to have it happen again within 10 minutes. Once we got North and the temperature settled down I was able to reset it and it stayed on the rest of the trip home to Ohio. Anyone have any ideas other than the heat? Seems excess heat shouldn't cause this to happen.
Pacostaco is online now   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:54 PM.