Thread Tools Display Modes
Old 08-06-2012, 03:29 PM   #1
Junior Member
Join Date: Aug 2012
Posts: 1
Question Generator pulled from Toyhauler fuel station doesnt work

Hello all,
I have a 2008 Energy Keystone 30ft Toyhauler
I purchased this Toyhauler from someone that had bought it at an auction. The 4000 Onan generator had been pulled. it looks like all the lines were just cut going to the generator. My toy has a fuel station yet i dont think there is power going to the fuel station i think when the generator was pulled they had to turn off the power to the fuel station. I am currently using a mobile 5000 generator but the fuel station does not work i put 10 gallons of gas, the timer works. yet no gas comes out of the pump. What could be wrong? what do i have to do to get the station working again?

MarcyFLaca is offline   Reply With Quote
Old 08-06-2012, 04:34 PM   #2
Senior Member
Poppy94's Avatar
Join Date: Jul 2012
Posts: 236
i got a puma TH and i'm not sure if our fueling stations are similiar or not. i had to subscribe to your thread. i'll trace my wiring out to see if it'll help you. i reckon you haven't used an ohm meter/voltmeter to check to see if you got electricity to your pump? i would presume there is a breaker in the main switch block that could be tripped or a fuse burned up. i'll check my wiring and report back. i hope it helps.

Poppy94 is offline   Reply With Quote
Old 08-06-2012, 05:11 PM   #3
Senior Member
Join Date: Oct 2009
Posts: 294
I had a2008 Raptor (biggest piece of junk I ever owned). If I recall, it only had one rear fuel station. Used for refueling toys- thats what the pump timer is for, and a line to the front that feeds the genny. There is no pump or wiring from the fuel supply to the genny. there should be a fuel fill nozzle ( like a gas station has) in the rear compartment to fuel your toys. The pump is only activated by the timer so you don't leave it on and burn the pump up. Look in the genny compartment for a line that is blocked off or cut. Or maybe they plugged it at the back.
MightyMike is offline   Reply With Quote
Old 08-11-2012, 07:27 PM   #4
Moderators' Assistant
bikendan's Avatar
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 10,154
since your trailer is not a FR product, there's a Keystone Owner's website that might be more helpful, since what you're asking is specific to your trailer.

here's the link:

Keystone RV Forums
Dan-Retired Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
'07 Roo 23SS pushing an '07 Chevy Avalanche
Equalizer WDH and Prodigy BC
bikendan is online now   Reply With Quote
Old 08-14-2012, 03:06 PM   #5
Senior Member
Poppy94's Avatar
Join Date: Jul 2012
Posts: 236
sorry i coudn't help. my wiring is intact and covered by the wire jacket. couldn't tell what colors are under there but i wasn't about to cut in to the jacket to check it out.
Poppy94 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:28 PM.