Reply
 
Thread Tools Display Modes
Old 06-10-2016, 08:45 PM   #11
Junior Member
 
Join Date: Aug 2015
Posts: 24
I seem to be having a problem that is similar to this post. Every other week over the winter I ran the RV at 4000 for an hour and everything was ok. I line in NY so it was below freezing. Now the generator runs for 10 to 20 minutes stutters and shuts down. The last code I saw was 3 then 6. There is fuel in the tank. Any ideas I am 2 weeks away from a cross country trip.
__________________

__________________
bdifonzo is offline   Reply With Quote
Old 06-10-2016, 09:00 PM   #12
Senior Member
 
Join Date: Jul 2014
Posts: 123
Agree, first place to look is the fuel pump. Airteck makes a replacement better than the OEM. You can find your manuals here Index of /~n0nas/manuals/onan
__________________

__________________
BBQGUY is offline   Reply With Quote
Old 06-10-2016, 09:11 PM   #13
Senior Member
 
Join Date: Jul 2014
Posts: 123
Fuel goes bad. Did you add a fuel stabilizer before you stored the unit for the winter? Assume you have done the yearly service (change oil, oil filter, fuel filter, air filter, new plugs). Most common problems are related to ethanol fuel, carburetors, and fuel pumps. Carburetors can not be rebuilt; replaced only.
__________________
BBQGUY is offline   Reply With Quote
Old 06-10-2016, 10:37 PM   #14
Member
 
Join Date: Sep 2014
Posts: 234
First check for trash in the carb bowl. Pinch off incoming fuel line first.
You can also rebuild the carb. Get the right kit, take apart and soak in amonia for an hour. Blow out all the passages and put back together.
__________________
2016 Flagstaff 27VRL with overloaded tires from factory
2015 Chevy Silverado
Paul GA is offline   Reply With Quote
Old 06-12-2016, 08:32 PM   #15
Junior Member
 
Join Date: Aug 2015
Posts: 24
Thanks everybody on Friday I ordered fuel pump, air filter, and fuel filter from Amazon. Arrived today. I installed and then ran the generator for two hours. Worked like it's supposed to.
__________________
bdifonzo is offline   Reply With Quote
Old 06-27-2016, 08:34 AM   #16
Junior Member
 
Join Date: Aug 2015
Posts: 24
More help needed. On a major road trip. My generator works when not moving for hours. When I start to drive it runs about 20 minutes. Any ideas?
__________________
bdifonzo is offline   Reply With Quote
Old 07-25-2016, 11:35 PM   #17
Senior Member
 
gmann55's Avatar
 
Join Date: Apr 2014
Posts: 196
Changed fuel pump on my 5500 watt gen and that solved the problem!
__________________

__________________
gmann55 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:56 PM.