Reply
 
Thread Tools Display Modes
Old 12-17-2014, 07:29 AM   #1
Junior Member
 
Join Date: May 2012
Posts: 25
Help.. No power from battery to TT 27hfs

Hoping someone can help me out. I am not getting any power from my battery to inside my camper. I know the battery is fine and the electric jack is working, all fuses and breakers in the main pannel look good. Is there a in line fuse from the main power coming into the camper from the battery that I might be missing?
__________________

__________________
2013 XLR 27HFS
2007 GMC Duramax
creed is offline   Reply With Quote
Old 12-17-2014, 08:01 AM   #2
Senior Member
 
Batts-toy's Avatar
 
Join Date: Apr 2013
Location: Ripon, California
Posts: 727
At the battery, starting at the positive post look for a small breaker that has tripped. Some are on the battery post, most are under the TT attached to the frame. Follow the positive wire the breaker it will be metal usually silver in color and some have a little black reset button. If you have a test meter test on each side to see if power goes through it. If it is the type with no reset button you will have to replace it.
__________________

__________________
Dale & Terri, Lulu & Tiki (our Chihuahua's), New rescue puppy Prince - Pom/Pug mix.
2013 Tundra, Double Cab, 5.7, TRD Off-Road, 4X4, Full Tow Package
2013 Wildwood T26TBSS - Sold
2000 Gulf Stream Sun Voyager M-8357 MH, Ford Trident V10 Gasser, 35 foot.
Batts-toy is offline   Reply With Quote
Old 12-17-2014, 08:07 AM   #3
Senior Member
 
Batts-toy's Avatar
 
Join Date: Apr 2013
Location: Ripon, California
Posts: 727
Another possibility is there are two 40 amp fuses in you electrical panel that protect the TT electrical circuits in case the battery gets hooked up backwards or the is a sudden large power flow, you should also check those f you haven't already.
__________________
Dale & Terri, Lulu & Tiki (our Chihuahua's), New rescue puppy Prince - Pom/Pug mix.
2013 Tundra, Double Cab, 5.7, TRD Off-Road, 4X4, Full Tow Package
2013 Wildwood T26TBSS - Sold
2000 Gulf Stream Sun Voyager M-8357 MH, Ford Trident V10 Gasser, 35 foot.
Batts-toy is offline   Reply With Quote
Old 12-17-2014, 08:29 AM   #4
Junior Member
 
Join Date: May 2012
Posts: 25
This is how the main power runs to the frame from the battery.
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1418822935458.jpg
Views:	134
Size:	71.8 KB
ID:	67629  
__________________
2013 XLR 27HFS
2007 GMC Duramax
creed is offline   Reply With Quote
Old 12-17-2014, 12:53 PM   #5
Senior Member
 
Join Date: Mar 2009
Location: Michigan
Posts: 123
We had the same problem last year. All our fuses were fine, battery fine. Converter had gone bad. If you plug into home/campground electric, do you have 110 (outlet) in the camper, but no DV (lights). If so, could be your converter, like us.
__________________
hotzfamily is offline   Reply With Quote
Old 12-17-2014, 01:03 PM   #6
Junior Member
 
Join Date: May 2012
Posts: 25
When plugged in the lights and outlets work.
__________________
2013 XLR 27HFS
2007 GMC Duramax
creed is offline   Reply With Quote
Old 12-17-2014, 02:18 PM   #7
Member
 
Grn_Mtns's Avatar
 
Join Date: Jun 2013
Location: Northern Vermont
Posts: 95
Our windjammer has a shut off switch with a red button for the DC up in the V nose. Do you have one? Look around.Could be anywhere!
It is easy to tap it closed. Good luck. If plugged in works then converter should be fine..
__________________
Best,
Grn_Mtns
____________________________________

2014 3025 Windjammer/260watts solar
Grn_Mtns is offline   Reply With Quote
Old 12-17-2014, 03:23 PM   #8
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 3,237
As Batts-toy mentionned see if there is small black button on side of breaker and press to re-set.....as shown in picture.
Attached Images
 
__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2008 F250 Lariat CC SB 6.8L V10 4.10 axle ratio (NITTO TERRA GRAPLER G2 LT275/65R20E)
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2011(21) 2012(36) 2013 (17) 2014 (18) 2015 (18) 2016 (36) 2017 (32)
fonzie is online now   Reply With Quote
Old 12-17-2014, 03:28 PM   #9
Maron
 
Join Date: Oct 2013
Posts: 253
Send a message via Yahoo to Maron
Call Forest River and talk to one of their techs up in Goshen...or is that Verbotten on this blog? They had a "Know Everything" electrical guy at the FROG convention but I can't remember his name. I even had him stop by our 8329 to help me out with the TV set up. It's a pain to get old.
__________________
Maron is offline   Reply With Quote
Old 12-17-2014, 04:04 PM   #10
Senior Member
 
Join Date: Dec 2014
Posts: 125
How about your battery terminals, could they be corroded and not making good contact?
__________________

__________________
saltyman is offline   Reply With Quote
Reply

Tags
battery, power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:52 AM.