Reply
 
Thread Tools Display Modes
Old 03-26-2016, 05:06 PM   #1
Member
 
Join Date: Mar 2014
Location: Rowlett, Texas
Posts: 49
Ignition to starter is dead

2012 Berkshire 360fws 340 hp cummins. Ready to start a new year and went to the storage to flow some juices and engine would not start. Well I assumed I had bad batteries since they were 5 yrs old. Charged the house up so I could use my aux start button. Aux start button was dead, so I took my carry around charger and plugged into the starter batteries all night. Went back next morning and still wouldn't start. Aux start button still will not light up. Well I went down today and bought new batteries installed 2 heavy rascals 950 cca each. NADA!!!! I checked all fuses that had anything to do with the ignition, double checked the tranny in N checked fuses in the converter dept that said ignition. Nothing. The fuel pump will energize, the trans pad will light up and the dash will light up, the steps stopped at halfway and will not move from that position. I'm stumped. Has anyone had anything similar? Thanks
__________________
RodneyD is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:12 PM.