Reply
 
Thread Tools Display Modes
Old 06-05-2012, 03:54 PM   #1
Senior Member
 
miatared's Avatar
 
Join Date: Oct 2009
Location: Toronto
Posts: 704
Inverter install problem ?

I installed my little 1000 Xantrex and it worked fine. Tested with an electric drill and TV.

Then I noticed I had not connected the 'frame ground screw', so I added a good ground connected to the trailer frame.

When I reconnected the Positive + on the battery post I blew the 80A fuse on that side of the inverter

No work no more....

Was that ground really necessary ?
__________________

__________________
Denis & Diane
2010 Sabre 31REDS
Ford F-250 2011
* Happy Campers *
miatared is offline   Reply With Quote
Old 06-05-2012, 03:58 PM   #2
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Quote:
Originally Posted by miatared
I installed my little 1000 Xantrex and it worked fine. Tested with an electric drill and TV.

Then I noticed I had not connected the 'frame ground screw', so I added a good ground connected to the trailer frame.

When I reconnected the Positive + on the battery post I blew the 80A fuse on that side of the inverter

No work no more....

Was that ground really necessary ?
I'm surprised it worked without ground.

Did u install a new fuse yet?

If not you most likely surged the fuse when you hooked up positive cable.

The inverter breakers should be off and disconnected when hooking up cables.
__________________

__________________
TURBS is offline   Reply With Quote
Old 06-05-2012, 04:16 PM   #3
Senior Member
 
miatared's Avatar
 
Join Date: Oct 2009
Location: Toronto
Posts: 704
No, I'll look at it again tomorrow as I have to leave now.

There's a Red POS + and a Black NEG - posts on the Xantrex, those both go to the battery, 1 GA cables, 5ft long, right next to the Pos + post there is a little screw, frame ground.

I am now wondering if I reversed my cables when I connected them back the inverter, doh...

Thanks, I'll check it out.
__________________
Denis & Diane
2010 Sabre 31REDS
Ford F-250 2011
* Happy Campers *
miatared is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:18 AM.