Thread Tools Display Modes
Old 04-07-2013, 12:20 PM   #1
Junior Member
Join Date: Apr 2013
Posts: 1
Inverter Problem

I have a 2012 Coachmen Sportscoach Pathfinder with a Magnum 2012 inverter which we purchased in October 2012. We used the inverter on a trip to Florida in December and it worked just fine. However, on a recent trip to Kentucky it stopped working half way from Michigan to Kentucky.

Upon our return home, I tried to determine why the inverter was not working. This is what I have done so far:

Read the owner’s manual (several times)

Checked to make sure the inverter is on and operating as instructed. The inverters green LED lights blinks when going through the charging stages as indicated in the owner's manual. I also opened the AC Access Panel to look to see if any of the wires came loose. I gently pulled on the wires to make sure they were tight. They were.

I checked the ME-RC Remote control and it shows that the inverter is charging and all the factor settings are correct.

All of the appliances work just fine when connected to shore power or when the generator is running.

However, when I disconnect the shore power and switch to the inverting mode none of the appliances (residential refrigerator and tv’s) work.

When fully charged the remotes screen reads “Full Charge DC: 13.7V + 0A”.

The indicator light on the RV show that the house batteries are at full charge.

When I extend a slide out the remote screen changes to “DC:13.7V + 24A” but then returns to 0A.

When I turn on the generator and ran it for about 20 minutes, then turned it off, and switched to inverting, the appliances still don’t work.

Does anyone know why the inverter is not working?


Schefjeff is offline   Reply With Quote
Old 04-08-2013, 06:45 AM   #2
Site Team - Lou
Herk7769's Avatar
Join Date: Oct 2009
Location: South Eastern PA
Posts: 19,832
Magnum 2012 Inverter Magnum ME-2012 2,000-watt 12VDC/120VAC off grid Inverter

I have to say this sounds like an awesome Inverter/battery charger! (except for the part where it is not working now ).

It sounds like the fuse between the battery and the Inverter/Charger has blown.
If you have the one I am thinking of, it can be reset by pushing the little button on the side of the fuse.

The indicator light on the RV just shows the voltage present in the distribution panel and NOT the voltage AT the house battery (which is most likely dead at this point).
Attached Images

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
Herk7769 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:06 PM.