Reply
 
Thread Tools Display Modes
Old 07-02-2016, 01:41 PM   #1
Junior Member
 
Join Date: Jul 2016
Posts: 6
Loss of electrical power.

I have a 2015 Forrest River Class C Sunseeker. I have lost all AC power within the RV. The generator is running, the circuit breakers writhin the RV are all good. The circuit breaker on the generator in not thrown, (is in the forward position). When connected to shore power (110v) I do have 110 power within. An external generator works as well.

I'm at a loss.

Does anyone have any suggestions?
__________________

__________________
garyjordan43 is offline   Reply With Quote
Old 07-02-2016, 02:03 PM   #2
Senior Member
 
Oaklevel's Avatar
 
Join Date: Sep 2012
Location: Virginia
Posts: 3,535
Transfer Switch Issue ????
__________________

__________________

2005 Dodge 3500 Cummins
2017 Wildwood Lodge 4092 BFL
1966 Mustang GT
1986 Mustang SVO
Sadie & Lillie Spoiled Rotten Boxers
Oaklevel is offline   Reply With Quote
Old 07-02-2016, 02:06 PM   #3
Junior Member
 
Join Date: Jul 2016
Posts: 6
Where would the transfer switch be located on my rig?
__________________
garyjordan43 is offline   Reply With Quote
Old 07-05-2016, 07:46 AM   #4
Junior Member
 
Join Date: Jan 2016
Posts: 9
Well this is interesting. I'm on here this am as the same thing is happening to us. We have same RV. What did you figure out as cause?
__________________
Jubowen is offline   Reply With Quote
Old 07-05-2016, 07:56 AM   #5
Site Team
 
wmtire's Avatar
 
Join Date: Nov 2010
Location: Northeast Louisiana
Posts: 15,043
Has it ever worked on generator power?

Not having a motorhome, I have read on these forums where some RV's, don't have a transfer switch, but you have to actually physically unplug your shore power cord, then plug in a generator plug in your compartment for the generator to provide power.

I have no idea if this applies to your situation, but let me see if I can find some of these threads, as I always believe in starting with the simple things first in troubleshooting.

Here is one recent on a Georgetown:

50 amp plug
__________________
2011 Flagstaff 831 RLBSS

Ducks are just all-terrain chickens
wmtire is online now   Reply With Quote
Old 07-05-2016, 08:02 AM   #6
Site Team
 
wmtire's Avatar
 
Join Date: Nov 2010
Location: Northeast Louisiana
Posts: 15,043
Here is another thread on the plug for a FR3, that may help go with my above post, to give you something to check:

Transfer switch location?
__________________
2011 Flagstaff 831 RLBSS

Ducks are just all-terrain chickens
wmtire is online now   Reply With Quote
Old 07-05-2016, 08:59 AM   #7
Junior Member
 
Join Date: Jan 2016
Posts: 9
This is the first time we have had this issue. We used the generator several weeks ago with no problems. We need to pull over and check reset button. He isn't sure where it's at but it can wait until later today when we get to our destination. Sucks to pull over for cup of coffee tho!!
__________________
Jubowen is offline   Reply With Quote
Old 07-05-2016, 01:06 PM   #8
Junior Member
 
Join Date: Jul 2016
Posts: 6
Quote:
Originally Posted by Jubowen View Post
Well this is interesting. I'm on here this am as the same thing is happening to us. We have same RV. What did you figure out as cause?
I have not gotten a chance to get it checked out as of yet. I will have it looked this week though and let you know.


thanks
__________________
garyjordan43 is offline   Reply With Quote
Old 07-05-2016, 03:05 PM   #9
Junior Member
 
Join Date: Jan 2016
Posts: 9
We called our dealer service guy. Seems my coffee pot draws too much power along with air conditioner and blew the breaker on the generator. Coffee pots and hair dryers are energy zappers. Once we reset the generator breaker, all was fixed.
__________________
Jubowen is offline   Reply With Quote
Old 07-05-2016, 03:26 PM   #10
Junior Member
 
Join Date: Jul 2016
Posts: 6
Yep. Seen that on YouTube. The breaker on the generator was not thrown.
__________________

__________________
garyjordan43 is offline   Reply With Quote
Reply

Tags
electric, electrical, power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:15 PM.