Reply
 
Thread Tools Display Modes
Old 07-31-2013, 05:11 PM   #1
dr ron
 
dr ron's Avatar
 
Join Date: Sep 2012
Location: dickson tn
Posts: 46
LP Gen will not start

I have a Onan Marquis 6500 LP Generator.
When I try to start it the cabin lights go dim and the solenoid clicks
Won't start
__________________

__________________
dr ron is offline   Reply With Quote
Old 08-01-2013, 02:01 PM   #2
Old Enough to Know Better
 
gasman6674's Avatar
 
Join Date: Feb 2012
Location: Greenwood, In
Posts: 462
Check the charge on your coach battery. Sounds like its flat. If you can plug into shore power it should recharge it but of course then you would not need the gen set.
__________________

__________________
Jim & Debbie England
Do you have Gas? 2015 F350 6.2L CCLB DRW 4.30 axle. 2012 Yellowstone Ridgeline 34RLT Fifth Wheel
gasman6674 is offline   Reply With Quote
Old 08-01-2013, 02:08 PM   #3
dr ron
 
dr ron's Avatar
 
Join Date: Sep 2012
Location: dickson tn
Posts: 46
Gen will not start

Thanks for the reply, the battery voltage is 13.7
I just got the unit back from Camping World. They put a new regulator on the Gen.
The solenoid was clicking when I took it in but they said it was OK.
Don't know why the light would dim though
They said they had it running for hours after the repair.
Beats me
__________________
dr ron is offline   Reply With Quote
Old 08-01-2013, 02:25 PM   #4
Old Enough to Know Better
 
gasman6674's Avatar
 
Join Date: Feb 2012
Location: Greenwood, In
Posts: 462
Is it Lp, Gas or Diesel? Lights dimming would be the load of the genny starter on the coach battery. Does it turn over at all?
__________________
Jim & Debbie England
Do you have Gas? 2015 F350 6.2L CCLB DRW 4.30 axle. 2012 Yellowstone Ridgeline 34RLT Fifth Wheel
gasman6674 is offline   Reply With Quote
Old 08-01-2013, 02:28 PM   #5
dr ron
 
dr ron's Avatar
 
Join Date: Sep 2012
Location: dickson tn
Posts: 46
It's an LP and no,the solenoid just clicks and the switch flashes 3 blinks pause 3 blinks pause and so on
__________________
dr ron is offline   Reply With Quote
Old 08-01-2013, 02:36 PM   #6
Old Enough to Know Better
 
gasman6674's Avatar
 
Join Date: Feb 2012
Location: Greenwood, In
Posts: 462
Have you tried it at the genset? On my old Itasca you could also start it at the genset. It also had some re-settable breaker switches in the battery compartment, one of mine had tripped. It just sounds to me that your coach battery isnt cutting it. Are all the connections clean? What does your manual say the blink code is?

PS sorry the thread title went in one ear and out the other :-)
__________________
Jim & Debbie England
Do you have Gas? 2015 F350 6.2L CCLB DRW 4.30 axle. 2012 Yellowstone Ridgeline 34RLT Fifth Wheel
gasman6674 is offline   Reply With Quote
Old 08-01-2013, 02:51 PM   #7
dr ron
 
dr ron's Avatar
 
Join Date: Sep 2012
Location: dickson tn
Posts: 46
It's too hard to get at to start at the unit.Camping World said the batteries are OK. The code says solenoid or other fault.There is an Onan service center in Nashville. That will be the next stop.It's not worth the grey hairs
Thanks mate.
__________________
dr ron is offline   Reply With Quote
Old 08-01-2013, 02:54 PM   #8
Old Enough to Know Better
 
gasman6674's Avatar
 
Join Date: Feb 2012
Location: Greenwood, In
Posts: 462
Cool

Good Luck
__________________
Jim & Debbie England
Do you have Gas? 2015 F350 6.2L CCLB DRW 4.30 axle. 2012 Yellowstone Ridgeline 34RLT Fifth Wheel
gasman6674 is offline   Reply With Quote
Old 08-01-2013, 03:40 PM   #9
Member
 
Join Date: Oct 2008
Location: Central Louisiana
Posts: 90
Try cleaning the battery posts
__________________
drc343 is offline   Reply With Quote
Old 08-01-2013, 03:53 PM   #10
dr ron
 
dr ron's Avatar
 
Join Date: Sep 2012
Location: dickson tn
Posts: 46
I can barely get my hand in the battery compartment to test them let alone clean them.
Camping World were supposed to have checked them and said they are OK.
I doubt if they cleaned them
__________________

__________________
dr ron is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:13 AM.