Reply
 
Thread Tools Display Modes
Old 07-31-2016, 03:48 PM   #1
Member
 
Join Date: Dec 2014
Posts: 58
No 110 power - please help

Just pulled in and set up but not getting any 110 to our Flagstaff 8528IKWS fifth wheel. House battery has shown signs of getting weak and I am going to replace but will/should that affect the 110?

I am running the 30 amp service thru a surge protector that shows good power.
Checked all fuses and circuit breakers... not sure how to troubleshoot from here.

Any help appreciated!
__________________

__________________
Darrell & Kathy
2013 Flagstaff 8528IKWS 5er
2013 Ford F250 6.7 Diesel
B&W Companion Slider
wdw0528 is offline   Reply With Quote
Old 07-31-2016, 03:51 PM   #2
Senior Member
 
SeaDog's Avatar
 
Join Date: Jan 2016
Location: Idaho
Posts: 1,958
The first are you getting 12V from the converter? second disconnect your shore power cord and test at the plug that goes into the rig to ensure power is making it to the rig. with circuit breakers they can look on and are not cycle them turn to off wait a few seconds and then back to on. let us know what you find
__________________

__________________
Retired Navy
Jake my sidekick (yellow Lab)
2017 RAM 2500 CC 4X4 Cummins Diesel
2016 Flagstaff 26 FKWS
AF&AM of Idaho
SeaDog is offline   Reply With Quote
Old 07-31-2016, 04:10 PM   #3
Site Team
 
Flybob's Avatar
 
Join Date: Oct 2014
Posts: 4,078
What surge protector? When you say shows good power what is indicator ( led/ meter)? Is the surge protector good? Try without surge protector if pedestal voltage and phase is correct.
__________________

2015 Freedom Express 248RBS
TV 2015 Silverado HD2500 Duramax
TST Tire Monitors
Honda 2000I + Companion
2 65W solar panels
Flybob is online now   Reply With Quote
Old 07-31-2016, 04:47 PM   #4
Member
 
Join Date: Dec 2014
Posts: 58
Update - although the surge protector (progressive industries) showed a good LED reading and voltage it was apparently not allowing it to flow thru (not sure why) but once removed I am in business.

Just no surge protection now.

Thanks for the quick replies!
__________________
Darrell & Kathy
2013 Flagstaff 8528IKWS 5er
2013 Ford F250 6.7 Diesel
B&W Companion Slider
wdw0528 is offline   Reply With Quote
Old 07-31-2016, 04:54 PM   #5
Senior Member
 
SeaDog's Avatar
 
Join Date: Jan 2016
Location: Idaho
Posts: 1,958
glad you figured it out and thanks for letting us know
__________________
Retired Navy
Jake my sidekick (yellow Lab)
2017 RAM 2500 CC 4X4 Cummins Diesel
2016 Flagstaff 26 FKWS
AF&AM of Idaho
SeaDog is offline   Reply With Quote
Old 07-31-2016, 05:12 PM   #6
Senior Member
 
Join Date: Jun 2015
Location: payson, az
Posts: 300
i had a problem once with power not going through a progressive industries energy system. the power readings showed that everything was good, yet no power to the trailer. it turns out the power readings (voltage and amperage) are taken from the input side of the device. in my case there was a piece of plastic inside the unit that kept the contactors from closing to route power to the output side.
__________________
CHICKDOE is online now   Reply With Quote
Old 07-31-2016, 06:20 PM   #7
Senior Member
 
HONDAMAN174's Avatar
 
Join Date: Jun 2011
Location: Big brown desert
Posts: 2,122
Quote:
Originally Posted by wdw0528 View Post
Update - although the surge protector (progressive industries) showed a good LED reading and voltage it was apparently not allowing it to flow thru (not sure why) but once removed I am in business.

Just no surge protection now.

Thanks for the quick replies!

I would get that looked at pronto. Don't want to be without protection!


2014 Evo 2850 "Woodstock"
2011 Toyota Tundra "Clifford"
__________________
2014 Stealth Evo 2850- "Woodstock"
2011 Toyota Tundra Rock Crawler TRD 5.7- "Clifford"
2013 Honda Accord Coupe V6 w/Track Pack- "Julia"

Just glad to get away
HONDAMAN174 is offline   Reply With Quote
Old 07-31-2016, 06:36 PM   #8
Senior Member
 
raspivey's Avatar
 
Join Date: Jun 2013
Location: Brazoria County, Texas
Posts: 1,276
Quote:
Originally Posted by CHICKDOE View Post
i had a problem once with power not going through a progressive industries energy system. the power readings showed that everything was good, yet no power to the trailer. it turns out the power readings (voltage and amperage) are taken from the input side of the device. in my case there was a piece of plastic inside the unit that kept the contactors from closing to route power to the output side.
I find it interesting that PI finds it necessary to include instructions to remove the cover on the contactors to make sure no plastic pieces fell in preventing them from opening in the event of an issue. At least, my hardwired 50A had those instructions. Sounds like a QC issue to me...having said that, mine didn't have that problem but, I'm guessing, a number have.
__________________
2012 Chevy Tahoe LTZ - HD tow package
2017 Rockwood 2703WS Emerald Edition
raspivey is offline   Reply With Quote
Old 07-31-2016, 07:36 PM   #9
Senior Member
 
Join Date: Jun 2015
Location: payson, az
Posts: 300
here's what happened about the plastic piece. I had a dealership install the ems. to do so they installed the ends of the heavy electrical cables into the terminals in the ems. they installed one of the cables deeper than it should have been. there is a plastic shield with fingers on it that goes over the contactors and is supposed to protect the contactors from having the cable pushed in too far and allowing the cable to touch the contactor. in my case I guess the installer just pushed the cable in and he broke the plastic protection finger. it then lodged in one of the contactors and prevented it from closing. the tech that installed the ems told me he plugged the unit into 50 amp power and got good readings from the ems box. however, when i went to use it i could not get any power out on one leg. i called progressive and they had me disassemble the covers and we got the broken finger out and then i got full power. they sent a new shield. i backed the power cable out a bit, installed the new shield and all is well. in talking to the progressive tech guy he said this happens. they were very nice and responsive!!! note - this is where i learned that all readings from the ems are taken from the input side of the unit. this is where all the monitoring is taking place.
__________________
CHICKDOE is online now   Reply With Quote
Old 07-31-2016, 09:24 PM   #10
Senior Member
 
HONDAMAN174's Avatar
 
Join Date: Jun 2011
Location: Big brown desert
Posts: 2,122
Quote:
Originally Posted by wdw0528 View Post
Update - although the surge protector (progressive industries) showed a good LED reading and voltage it was apparently not allowing it to flow thru (not sure why) but once removed I am in business.

Just no surge protection now.

Thanks for the quick replies!

I would get that looked at pronto. Don't want to be without protection!


2014 Evo 2850 "Woodstock"
2011 Toyota Tundra "Clifford"
__________________

__________________
2014 Stealth Evo 2850- "Woodstock"
2011 Toyota Tundra Rock Crawler TRD 5.7- "Clifford"
2013 Honda Accord Coupe V6 w/Track Pack- "Julia"

Just glad to get away
HONDAMAN174 is offline   Reply With Quote
Reply

Tags
power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:59 PM.