Reply
 
Thread Tools Display Modes
Old 05-23-2012, 11:47 AM   #1
Junior Member
 
Join Date: Apr 2012
Posts: 4
No 12v lights working on LR slide

My 02 class A diesel pusher's living room slide does not have any 12v power. The lights flickered one evening and did not work the next day. I have checked the fuses and the wiring going to the slide....nothing! Also, the inside tanks, LP
__________________

__________________
Mrgary is offline   Reply With Quote
Old 05-23-2012, 11:54 AM   #2
Junior Member
 
Join Date: Apr 2012
Posts: 4
[QUOTE="Mrgary"]My 02 class A diesel pusher's living room slide does not have any 12v power. The lights flickered one evening and did not work the next day. I have checked the fuses and the wiring going to the slide....nothing! Also, the inside tanks, LP indicator lights and water pump switch are not functioning.
Any help would be appreciated!
Gary R
__________________

__________________
Mrgary is offline   Reply With Quote
Old 05-23-2012, 11:58 AM   #3
Junior Member
 
Join Date: Apr 2012
Posts: 4
[QUOTE="Mrgary"]My 02 class A diesel pusher's living room slide does not have any 12v power. The lights flickered one evening and did not work the next day. I have checked the fuses and the wiring going to the slide....nothing! Also, the inside tanks, LP, light indicators and water pump switch do not function.
HELP!!!!!
GARY
__________________
Mrgary is offline   Reply With Quote
Old 05-23-2012, 12:37 PM   #4
Senior Member
 
Fire Instructor's Avatar
 
Join Date: Jul 2010
Location: Upstate (Albany Area) NY
Posts: 772
If, as you say, the wires and fuse are intact, then it sounds like the slide lost it's ground. Try jumping the metal slide frame to a good chassis ground, and see if the lights come on.
__________________
Fire Instructor

2014 RAM 2500 Laramie 4x4 Quad Cab w/Cummins Turbo Diesel, 2009 Rockwood 2607, and 3 'yaks!
300W of Suntech Solar, a Rogue MPT-3024 Controller, and a Xantrex PW2000 Inverter
Fire Instructor is offline   Reply With Quote
Old 05-23-2012, 08:58 PM   #5
Junior Member
 
Join Date: Apr 2012
Posts: 4
Thank you for responding to my problem.
Grounding the slide did not help. I have an audible continuity checker and it beeps when I touch one to the slide and one to the chassis. I even attached battery jumper cables to the slide and chassis
I feel that it must be a loose connection as all other 12v lights and fans work. There is no 12v power at all in the slide and no power to the tank info panel and water pump switch
Any other suggestions?
__________________
Mrgary is offline   Reply With Quote
Reply

Tags
12 Volt

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:00 AM.