Reply
 
Thread Tools Display Modes
Old 10-18-2014, 09:17 PM   #1
Junior Member
 
Join Date: Oct 2014
Posts: 9
No power at thermostat

I discovered on my last trip I had no heat. and If I wanted AC I wouldn't have it either. Then I discovered my vent-a-hood wouldn't run either even though the light did. I took the thermostat cover off and found I didn't have power on the 7.5v terminal. I do have ceiling lights, but don't believe they are as bright as they should be. Yes, I checked the fuses with a meter and they are OK. Questions: are there schematics available to trace this lack of power? Or does anyone know where the power comes from to supply the thermostat? Are there hidden fuses other than the ones in the elec. panel?
Thanks for any info..
Lee G
2008 FR Cherokee 5er
33ft
__________________

__________________
Lee G is offline   Reply With Quote
Old 10-18-2014, 09:30 PM   #2
Senior Member
 
jimdd810's Avatar
 
Join Date: Sep 2014
Posts: 141
Check your battery


Life is a highway!!!!!
__________________

__________________
jimdd810 is offline   Reply With Quote
Old 10-18-2014, 09:41 PM   #3
Junior Member
 
Join Date: Oct 2014
Posts: 9
Battery, yes I have that on my list and thanks. I hate to start tearing this thing down and find out it was something simple.
__________________
Lee G is offline   Reply With Quote
Old 10-19-2014, 03:56 PM   #4
Junior Member
 
Join Date: Oct 2014
Posts: 9
The Battery checks out ok, next stop,,,the inverter
__________________
Lee G is offline   Reply With Quote
Old 10-19-2014, 04:12 PM   #5
Senior Member
 
jonrjen's Avatar
 
Join Date: Sep 2013
Location: TEXAS
Posts: 766
Wouldn't make any sense, but have you tried resetting your GFI circuits? I've seen stranger things happen on a RV.

How about the resettable breaker that is usually located down on the bulkhead wall behind the battery?
__________________
2013 Ford F350 FX4 4x4 PSD
2013 Wildcat 353LS

2015 Day/Nights Camped 5
2014 Day/Nights Camped 29
jonrjen is offline   Reply With Quote
Old 10-19-2014, 06:29 PM   #6
Junior Member
 
Join Date: Oct 2014
Posts: 9
Thanks for your suggestions: This is what I found to date in case there is someone else looking for answers. The power for the thermostat comes from the dometic AC. I found a 3A fuse there which was blown. I didn't have a 3A fuse so I use the next best size which was a 5A. The AC tried to start, but didn't sound right so I shut it down as the fuse blew at the same time. I suspect (WAG) a start capacitor is the culprit. I'll know more when I take it to my service man who knows what he is doing. more later.

Lee
08 FR Cherokee 5er
02 Ford F250 7.3
__________________

__________________
Lee G is offline   Reply With Quote
Reply

Tags
power, thermostat

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:52 AM.