Reply
 
Thread Tools Display Modes
Old 09-17-2016, 08:53 AM   #1
Junior Member
 
Join Date: Sep 2016
Posts: 2
No power when unplugged

I am new to the forum. I have read many of the posts and responses and am thankful to have found this site. I too, have had multiple issues with this trailer to the point of just finding a reliable service center and paying them to repair everything.
Newest/current problem. I couldn't bring in the slides. Talked with forest river, and even though I was plugged into power, they suggested replacing batteries. Did that, and slides came in. The problem is that when not plugged into power, the trailer is dead. No power whatsoever! Can it be as simple as a converter fuse? I don't even know where the converter is located. Any advice? Thanks
__________________

__________________
BrianM is offline   Reply With Quote
Old 09-17-2016, 09:01 AM   #2
Senior Member
 
Ford Idaho's Avatar
 
Join Date: Sep 2013
Location: Idaho
Posts: 9,790
One like this should be near the battery of your unit what ever it is.



Press the little black button.

Does what ever unit you got have one of these?



Is set so the battery connected?
__________________

__________________
2016 F350 6.7L LB CC Reese 28K 2014 Chaparral Lite 266sab
"Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety." 2014 19 days camping 2015 17 days camping201620 days camping
Ford Idaho is offline   Reply With Quote
Old 09-17-2016, 09:15 AM   #3
Junior Member
 
Join Date: Sep 2016
Posts: 2
Sorry, its a 2015. 3030 rs.
Ok Ford Idaho, I dont want to admit this, but yes the battery disconnect was engaged. If not for your response, I would have driven myself nuts all weekend trying to fix the "non problem". This is my 4th trailer and i know what a disconnect switch is, problem is it just couldn't have been that simple. Thank you!!!!
__________________
Brian
2015 Cardinal 3030RS
F350
BrianM is offline   Reply With Quote
Old 09-17-2016, 12:03 PM   #4
Senior Member
 
Ford Idaho's Avatar
 
Join Date: Sep 2013
Location: Idaho
Posts: 9,790
I do hope all is well now.

I hooked the lite up for our last trip out this year.

Could not figure out why the trailer brakes would not work, battery was disconnected once I figured it out I face palmed myself...
__________________
2016 F350 6.7L LB CC Reese 28K 2014 Chaparral Lite 266sab
"Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety." 2014 19 days camping 2015 17 days camping201620 days camping
Ford Idaho is offline   Reply With Quote
Old 09-18-2016, 01:55 PM   #5
Senior Member
 
Join Date: Jun 2016
Location: Mid Michigan
Posts: 309
been there done that. The disconnect on our last tt was actually in one of the storage compartments. Taking something out of storage, I bumped the switch and everything was off.
__________________
markb422 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:09 AM.