Reply
 
Thread Tools Display Modes
Old 07-21-2014, 03:44 PM   #1
Junior Member
 
Join Date: Jul 2014
Posts: 1
No Shore power. Generator power is good

I have a Berkshire 39 foot 50 amp. Went to use shore power over the weekend and got no power. Generator power works entire coach + AC 2 units. Turned off generator and plugged in and nothing. All breakers are on. Generator breaker is on. not tripped. Box in cabinet with shore power cord makes a clucking sound when generator is on. Generator RPM's fluctuate low to high just before the clunking sound in box. Does the ACV box need replacement? Any help would be great.
__________________

__________________
samsnead is offline   Reply With Quote
Old 07-21-2014, 04:22 PM   #2
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Sounds like a bad or faulty transfer switch.

"sabre owners united!"


turbs
__________________

__________________
TURBS is offline   Reply With Quote
Old 07-22-2014, 07:11 AM   #3
Junior Member
 
Join Date: Jul 2014
Posts: 3
Just had that same issue. Check the transfer switch. Mine had some fried connections on the shore power leads while the generator leads were still okay. Quick change-out on the box and we were good to go.


Sent from my iPhone using Forest River Forums
__________________
familycamper5 is offline   Reply With Quote
Reply

Tags
generator, power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:01 AM.