Reply
 
Thread Tools Display Modes
Old 11-10-2015, 02:39 PM   #1
Senior Member
 
Steveanddianne's Avatar
 
Join Date: Jul 2015
Location: Rhode Island
Posts: 129
Not working Furrion F30R30-SB Black 30' 30 Amp Cordset

Has anyone had a problem with this product? When we plugged it in to the RV we got the Blue light so we new we had power at the RV, but on the other end of the cord there was not light saying we were receiving power. I checked the source and we did have incoming power, the the indicator light was not on. Is there a fuse in this? or is just a malfunction.
__________________

__________________
Steveanddianne is offline   Reply With Quote
Old 11-11-2015, 09:35 AM   #2
Senior Member
 
rsscully's Avatar
 
Join Date: Aug 2014
Posts: 183
I have the same lighted cord and light on outlet on rv, both Furion. Neither light works after a year of use. Both the cord and the outlet function fine other then the lights.
__________________

__________________
rsscully is offline   Reply With Quote
Old 11-11-2015, 09:52 AM   #3
Pickin' & Campin'
 
5picker's Avatar
 
Join Date: Aug 2015
Location: South Western PA
Posts: 4,998
There have been many documented cases of the LED indicator lights becoming inoperative in these cord sets. Some, after a period of use and some, the first or second time of use.
The cord set should function fine without the indicators. If under warranty you 'may' want to have it replaced but don't expect the replacement to last much longer.
__________________
_________________________________________
2016 Flagstaff 8529IKBS Diamond Package 5th Wheel
2017 Ford F-Series SCREW 4x4
TST Tire Monitor w/Repeater - Sinemate 3500w Gen.
Days Camped: '15=22 '16=46 '17=30
5picker is online now   Reply With Quote
Old 11-11-2015, 10:12 AM   #4
Senior Member
 
Join Date: Oct 2015
Posts: 2,270
Go to Furrion.com and send them an email using the link in the support section. They'll send you a new one. They supposedly had a bad batch of cords awhile back. They don't advertise it, but they will send you a new cord set. The replacement they sent me over a year ago is still ok. They were supoosed to send me a return shipping label with the replacement to send the bad one back but they didn't. I bought a female end and made a nice extension cord out of it....sort of like a bonus.
__________________
Mr Havercamp is offline   Reply With Quote
Reply

Tags
black

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:19 PM.