Reply
 
Thread Tools Display Modes
Old 05-07-2016, 11:20 PM   #1
Senior Member
 
Sagecoachdriver's Avatar
 
Join Date: Jun 2015
Location: Southern California
Posts: 1,466
Onan 4KW cranks, doesn't start

My Onan 4KWQ generator with 50 hours in my 8 month old 2016 Forester wouldn't start Thursday morning as we were about to head home from Yosemite. It would crank but as soon as I released the start button it died. I checked and there was 3/4 tank of gas and the batteries we 90%. I then checked the carburetor choke and it was working and I could smell gas. We had plenty of battery power to bring in the slides and raise the levelers. I was able to get 1 4 trouble code which is high frequency. Once at Oakhurst, CA (cell service was intermittent in Yosemite Valley) I called my dealer and he referred me to a local Onan authorized repair shop close by. I called them and the said to bring it in yesterday at 8am. After much testing, the said the generator had to be removed as the problem lies internally. Late yesterday, I spoke with them and they said it was the bushings and that it appears there was some debris or something there. Anyway, they had the bushing assembly and it's back running. They need to finish reassembly and I can come in Monday afternoon to have the generator reinstalled. Under warranty, no charge!
Anyone else have issues like this? How easy is it to replace the bushings and does the generator really need to be removed?
__________________

__________________
2004 Winnebago Minnie 22e(went to a nice family Oct 3, 2015)
2016 Forester 2701DS (Aug 31, 2015)
2017 Camping 10 trips 32 nights
Sagecoachdriver is offline   Reply With Quote
Old 05-12-2016, 01:25 AM   #2
Senior Member
 
Sagecoachdriver's Avatar
 
Join Date: Jun 2015
Location: Southern California
Posts: 1,466
Back in and running

They reinstalled the generator and everything seems to be fine. Does seem a bit noisier than before.
__________________

__________________
2004 Winnebago Minnie 22e(went to a nice family Oct 3, 2015)
2016 Forester 2701DS (Aug 31, 2015)
2017 Camping 10 trips 32 nights
Sagecoachdriver is offline   Reply With Quote
Old 05-12-2016, 01:50 AM   #3
Senior Member
 
benagi's Avatar
 
Join Date: Mar 2015
Location: Utah
Posts: 631
Quote:
Originally Posted by Sagecoachdriver View Post
They reinstalled the generator and everything seems to be fine. Does seem a bit noisier than before.

Sage, that is some bad luck. Haven't heard Onan having that type of problem so soon. Hope you won't have to go thru that again.
__________________
1968 tent trailer
1985 Jamboree 23 ft
1997 Minnie Winnie 25 Ft
2016 Forester 3171DS (ordered March & arrived June 2015)
benagi is offline   Reply With Quote
Old 05-12-2016, 02:02 AM   #4
Senior Member
 
Sagecoachdriver's Avatar
 
Join Date: Jun 2015
Location: Southern California
Posts: 1,466
Quote:
Originally Posted by benagi View Post
Sage, that is some bad luck. Haven't heard Onan having that type of problem so soon. Hope you won't have to go thru that again.
I know, I never had an issue like that with the same Onan in my 04 Winnebago Minnie. The authorized service center said it's not common, but does happen. I exercise mine religiously plus monthly campouts.
__________________
2004 Winnebago Minnie 22e(went to a nice family Oct 3, 2015)
2016 Forester 2701DS (Aug 31, 2015)
2017 Camping 10 trips 32 nights
Sagecoachdriver is offline   Reply With Quote
Old 05-15-2016, 12:00 AM   #5
Senior Member
 
Sagecoachdriver's Avatar
 
Join Date: Jun 2015
Location: Southern California
Posts: 1,466
Smoking, leaking fuel and stopped

After re-installing the generator Monday, I have run it every day this week for at least an hour with the air conditioner on while I was working on the slide-out fascia. Then this afternoon, I got a lot of white smoke and it died. Had gas dripping from the air filter housing. Tried a few more times still smoking and died. Flashing 3 6. About an hour later, I tried again and it was working. I let it run for 30 minutes and shut it down. Just went out and tried to start it, sputters and won't start. I used my flashlight to see if there was fuel dripping and saw none. However, I noticed the label on the fuel pump was ready to come off and there was grey foam extruded from 2 spots on the pump. Could the pump be defective and release debris that clogged the carb?
Attached Thumbnails
Click image for larger version

Name:	IMG_1699.JPG
Views:	37
Size:	108.0 KB
ID:	107912  
__________________
2004 Winnebago Minnie 22e(went to a nice family Oct 3, 2015)
2016 Forester 2701DS (Aug 31, 2015)
2017 Camping 10 trips 32 nights
Sagecoachdriver is offline   Reply With Quote
Old 05-18-2016, 02:21 PM   #6
Senior Member
 
Sagecoachdriver's Avatar
 
Join Date: Jun 2015
Location: Southern California
Posts: 1,466
Left a message at Scandavia Service, authorized Onan service, and they called back early Monday morning. I explained the symptoms and that we were about to leave on a week log trip. They said bring it right in. After a thorough check, it was determined to be a faulty fuel pump producing high psi. they replaced the fuel pump along with the air filter that was soaked with gas. All under warranty.
Got a late start but made it to the CG by 9pm.
Generator is working fines, no more issues. Thanks Scandanavia Service in Simi Valley
This had nothing to do with the earlier issue with the brushes.
__________________
2004 Winnebago Minnie 22e(went to a nice family Oct 3, 2015)
2016 Forester 2701DS (Aug 31, 2015)
2017 Camping 10 trips 32 nights
Sagecoachdriver is offline   Reply With Quote
Old 05-19-2016, 01:22 PM   #7
Member
 
Join Date: Sep 2012
Posts: 68
Sage, I too have been very happy with the service and expertise at Scandinavian Service. Thanks for the post
__________________

__________________
campingtom is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:51 AM.