Thread Tools Display Modes
Old 04-21-2016, 11:29 AM   #1
Junior Member
Join Date: Aug 2015
Posts: 21
overhead lights delay before lighting

Hello All,

2015 Salem Cruise Lite 195BH

So one of my overhead lights is messing up (bathroom light)... you flick the switch, and it takes anywhere from 1 to 10 seconds before it turns on. Kinda strange!

It is one of the standard double-bulb, 12V, built-in switch light fixtures I see in so many campers with the original incandescent bulbs. Once on, it stays on and is normal brightness. I don't hear or see anything unusual. There is no condensation in the lenses at all. We are hooked up to shore power.

Anyone had this problem?


s10texan is offline   Reply With Quote
Old 04-21-2016, 12:07 PM   #2
Senior Member
Join Date: Feb 2015
Posts: 429
Try changing the bulb

2016 Flagstaff 23lb
Toddupton is offline   Reply With Quote
Old 04-21-2016, 04:30 PM   #3
Senior Member
Join Date: Mar 2014
Location: Mountain Foothills of Southern Alberta
Posts: 519
Try taking the bulbs out and clean the contacts the best you can (bulb and fixture).

2007 Surveyor SV230
- 200 Watts Solar/MPPT Controller - 230 AH Battery Bank - 600 watt PSW Inverter - (2) 2000 watt Inverter Generators - LED Lighting - Boon Docking 99% of the time.
2009 F150 - 5.4 Litre - 6 speed - Tow Package
boondocking is offline   Reply With Quote
Old 04-21-2016, 05:32 PM   #4
Junior Member
Join Date: Aug 2015
Posts: 21
Well I took the fixture down, wiggled the wires, and now it works. Must have been a loose wire. Aggravating, because I don't know which connector was bad. Oh well!

s10texan is offline   Reply With Quote
Old 04-21-2016, 05:42 PM   #5
Site Team
Flybob's Avatar
Join Date: Oct 2014
Posts: 3,207
Could be just some corrosion on the connection or contacts as the bathroom probably sees more humidity than other parts of the rig. Might try a light coat of anti-oxidizing compound on bulb/socket.

2015 Freedom Express 248RBS
TV 2015 Silverado HD2500 Duramax
TST Tire Monitors
Honda 2000I + Companion
2 65W solar panels
Flybob is offline   Reply With Quote
Old 04-21-2016, 06:33 PM   #6
Senior Member
Forbes's Avatar
Join Date: Jan 2012
Location: Tennessee
Posts: 566
Connection problem some where or it could be you have a battery that has some slow electrons and they are playing with you. LOL
Roger & Mary Forbes
Little Lady (Dog)
2014 F350 / 2015 CC 36 CKTS
Days Camping 2014-96, 2015-130, 2016-85 and counting
Forbes is online now   Reply With Quote
Old 09-13-2016, 08:27 PM   #7
Junior Member
Join Date: Aug 2015
Posts: 21
Well its a late update, but it was the switch in the fixture that was bad. Replaced it and no more issues.


s10texan is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:34 AM.