Reply
 
Thread Tools Display Modes
Old 05-08-2015, 04:09 AM   #11
Moderators' Assistant
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 13,269
Quote:
Originally Posted by airforceguyiniowa View Post
Fridge and microwave do not power up


Sent from my iPhone using Forest River Forums
That doesn't make sense.
The microwave is 110v AC only, not 12v DC.
Why is tv and outlets working but not microwave?
Can't just be a 12v issue.
__________________

__________________
Dan-Retired Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
2016 PrimeTime TracerAIR 255, pushing a 2014 Ford F150 4x4 3.5 Ecoboost w/Max Tow Package
Equalizer WDH and Prodigy BC
bikendan is offline   Reply With Quote
Old 05-08-2015, 07:49 AM   #12
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Fridge is 12v "battery powered" microwave is 110v "shore power"

1] you should have "2" gfci outlets.
One in bathroom and one in kitchen.

2) check 12v fuses in converter for fridge and also there's 2 fuses outside in the fridge access panel in a black box

TURBS
08 duramax tuned n modded, 32bhok Sabre
2015 camping "4 nights"
__________________

__________________
TURBS is offline   Reply With Quote
Old 05-08-2015, 08:36 AM   #13
Senior Member
 
jtstromsburg's Avatar
 
Join Date: Jul 2011
Location: Stromsburg, Nebraska
Posts: 1,654
Check those two big red 40a fuses near the smaller ones. I haven't had to deal with this exact issue. So am not sure what to look for, but I know there's fuses you can't usually see until you take things apart like you have here. Keep looking at those higher amperage fuses
__________________
Joel and Teresa
2016 Sabre 34TBOK
2006 GMC 3500 CC LB DRW 4X4
jtstromsburg is offline   Reply With Quote
Old 05-08-2015, 08:50 AM   #14
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Your camper is still under warranty is it not?


TURBS
08 duramax tuned n modded, 32bhok Sabre
2015 camping "4 nights"
__________________
TURBS is offline   Reply With Quote
Old 05-08-2015, 10:06 AM   #15
Junior Member
 
airforceguyiniowa's Avatar
 
Join Date: May 2014
Posts: 15
Probably, it's a 2014 model, just want to make sure if its something I can fix, dealer is a pain, takes forever, and Memorial Day is fast approaching.


Sent from my iPhone using Forest River Forums
__________________
airforceguyiniowa is offline   Reply With Quote
Old 05-08-2015, 10:08 AM   #16
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
To bad your not a little closer I'd run over n help you out.

TURBS
08 duramax tuned n modded, 32bhok Sabre
2015 camping "4 nights"
__________________
TURBS is offline   Reply With Quote
Old 05-08-2015, 10:09 AM   #17
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
First you need to look in the frf library and look at the wfco trouble shooting guide.

Is your battery dead in camper?

TURBS
08 duramax tuned n modded, 32bhok Sabre
2015 camping "4 nights"
__________________
TURBS is offline   Reply With Quote
Old 05-08-2015, 10:14 AM   #18
Site Team
 
wmtire's Avatar
 
Join Date: Nov 2010
Location: Northeast Louisiana
Posts: 15,020
My question was similar to Turbs, and wanted to make sure you have a battery in your RV and have you recently connected or disconnected it?
__________________
2011 Flagstaff 831 RLBSS

Ducks are just all-terrain chickens
wmtire is online now   Reply With Quote
Old 05-08-2015, 10:19 AM   #19
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
We know it's not the curcuit breaker under the A-frame because 12v is getting in from your truck.
So.
1) dead / junk battery.
2) blown reverse polarity fuses.
3) bad converter and dead battery.

TURBS
08 duramax tuned n modded, 32bhok Sabre
2015 camping "4 nights"
__________________
TURBS is offline   Reply With Quote
Old 05-08-2015, 12:34 PM   #20
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 3,237
Check the two 40 amps fuses to see if burnt. If these are burnt then most likely your battery is hooked backwards, if all OK then go check underneath trailer near tongue for a mini-breaker and press black button to reset....tat is a start.
Attached Thumbnails
Click image for larger version

Name:	Breaker Box.jpg
Views:	64
Size:	59.1 KB
ID:	76436   Click image for larger version

Name:	mini-breaker pic.jpg
Views:	65
Size:	30.1 KB
ID:	76437  
Attached Images
 
__________________

__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2008 F250 Lariat CC SB 6.8L V10 4.10 axle ratio (NITTO TERRA GRAPLER G2 LT275/65R20E)
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2011(21) 2012(36) 2013 (17) 2014 (18) 2015 (18) 2016 (36) 2017 (32)
fonzie is online now   Reply With Quote
Reply

Tags
camper, power, truck

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:33 AM.