Reply
 
Thread Tools Display Modes
Old 09-04-2015, 10:28 PM   #1
Junior Member
 
Join Date: Apr 2012
Posts: 10
Power problem

We have a Forest River Shamrock hybrid 2012. Suddenly an electrical problem. Batteries have a 75% charge as shown on the Noco Genius, and even without the shore line the winch has power. No power however, inside whatsoever. Have checked the battery connections which are right. Have reset the breakers, still dead. Thoughts?
__________________

__________________
Mike Ridges is offline   Reply With Quote
Old 09-05-2015, 12:02 AM   #2
Senior Member
 
HONDAMAN174's Avatar
 
Join Date: Jun 2011
Location: Big brown desert
Posts: 2,318
Follow power lines from battery under the trailer. You should find a resettable circuit breaker.
__________________

__________________
2014 Stealth Evo 2850- "Woodstock"
2011 Toyota Tundra Rock Crawler TRD 5.7- "Clifford"
2013 Honda Accord Coupe V6 w/Track Pack- "Julia"

Just glad to get away
HONDAMAN174 is offline   Reply With Quote
Old 09-05-2015, 05:59 AM   #3
Moderators' Assistant
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 13,278
Quote:
Originally Posted by Mike Ridges View Post
We have a Forest River Shamrock hybrid 2012. Suddenly an electrical problem. Batteries have a 75% charge as shown on the Noco Genius, and even without the shore line the winch has power. No power however, inside whatsoever. Have checked the battery connections which are right. Have reset the breakers, still dead. Thoughts?
don't know what a Noco Genius is, but what winch are you talking about?
hybrids don't have winches.

as far as power inside, are you talking about 120v AC, like the outlets and microwave?
or are you talking about the 12v DC stuff, like the lights, furnace fan?

setting breakers are for 120v AC ONLY.
fuses are for 12v DC ONLY.

it would help if you told us which electrical side you're talking about, AC or DC.
and what model of Shamrock do you have?
__________________
Dan-Retired Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
2016 PrimeTime TracerAIR 255, pushing a 2014 Ford F150 4x4 3.5 Ecoboost w/Max Tow Package
Equalizer WDH and Prodigy BC
bikendan is online now   Reply With Quote
Old 09-05-2015, 06:37 AM   #4
Senior Member
 
Join Date: Jul 2010
Location: Waynesville
Posts: 12,019
Quote:
Originally Posted by Mike Ridges View Post
We have a Forest River Shamrock hybrid 2012. Suddenly an electrical problem. Batteries have a 75% charge as shown on the Noco Genius, and even without the shore line the winch has power. No power however, inside whatsoever. Have checked the battery connections which are right. Have reset the breakers, still dead. Thoughts?
Just a WAG but check the 2 fuses in the middle of your Converter,if they are blown you will NOT have 12V power! Youroo!!
__________________
youroo is offline   Reply With Quote
Old 09-05-2015, 12:23 PM   #5
Junior Member
 
Join Date: Apr 2012
Posts: 10
Thanks for all your replies. Very much appreciated. Lots of learning experiences with this problem and attempts to diagnose. Ended up taking the trailer to the dealer who was miraculously staffed in the service dept today. Turns out it was loose screws on the battery disconnect. Problem fixed. On our way to the mountains now. You folks are great. Thanks again. P.S. The Noco Genius is our battery charger.
__________________
Mike Ridges is offline   Reply With Quote
Reply

Tags
power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:25 PM.