Reply
 
Thread Tools Display Modes
Old 01-08-2016, 04:46 PM   #1
Member
 
Join Date: May 2015
Location: Brooksville,Fl
Posts: 81
Send a message via Yahoo to carluv
Steps

Having a step problem, besides the bolt shearing off. That is another story.
Had steps replaced after bolt problem , and now they don't want to go in. If the engine is running and you get out and close the door, it may take 2-3 min before they go in. If they go i and you open the door again right away, they will not come out and you have to climb out the door or climb in if you are outside.
Anyone else have this problem?
__________________

__________________
carluv is offline   Reply With Quote
Old 02-12-2016, 09:51 PM   #2
Senior Member
 
SeaDog's Avatar
 
Join Date: Jan 2016
Location: Idaho
Posts: 3,417
check the electrical connections to the steps, I had a problem with the steps and that what it was the wires were corroded and not passing enough amps for the motor to run as it should
__________________

__________________
Retired Navy
Jake my sidekick (yellow Lab)
2017 RAM 2500 CC 4X4 Cummins Diesel
2016 Flagstaff 26 FKWS
AF&AM of Idaho
SeaDog is offline   Reply With Quote
Old 02-13-2016, 07:38 AM   #3
Member
 
Join Date: May 2015
Location: Brooksville,Fl
Posts: 81
Send a message via Yahoo to carluv
SeaDog,
Thanks for the info. I will check the wires and see what happens.m
__________________
carluv is offline   Reply With Quote
Old 02-13-2016, 07:58 AM   #4
Senior Member
 
bubbles's Avatar
 
Join Date: Dec 2012
Posts: 2,561
One issue that is common to both your issues is a good ground. The large green wire that is grounded to the step chassis is the main grounding point but the mounting bolts for the steps must also make a good ground through the unit. These points should be bonded metal to metal (no paint between points etc.). Another common issue is the step controller itself.
__________________
bubbles is offline   Reply With Quote
Old 02-13-2016, 11:38 AM   #5
Member
 
Join Date: May 2015
Location: Brooksville,Fl
Posts: 81
Send a message via Yahoo to carluv
Bubbles,

Thanks for the info. I will check all the grounds first, but I think it is the controller also. The new steps worked fine for the first 2-3 months. I will clean all the connections and see what happens. I looked up under the steps and all the wires were tight, but will keep everyone posted.

They are still under warranty if I can't get them working right. Hate taking it to the RV shop.
__________________
carluv is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:56 AM.