Reply
 
Thread Tools Display Modes
Old 04-30-2014, 12:20 PM   #1
Member
 
Join Date: Apr 2011
Posts: 34
Surge Guard 34750

Hi,

We have a two year old Surge Guard 34750 (out of one year warranty) and it never goes out of "delay" when first attached to the power source. It makes the clunk sound at the end of each two minute cycle but never goes to green light. Is there a way to test them? It has done its job several times over the last two years and I'm hesitant to go without it.

Thanks,

Tom
__________________

__________________
irish01 is offline   Reply With Quote
Old 04-30-2014, 12:31 PM   #2
Senior Member
 
Road-King's Avatar
 
Join Date: Jul 2012
Location: TN
Posts: 645
I assume you have tried it with another known good power source?
__________________

__________________
Russ & Kim
2014 Alpine 3600RS
2007 Dodge Ram 3500 5.9 4X4
2008 Harley Davidson Road King 105th Anniversary
(2011-5 bad year)(2012-40)(2013-45)(2014-23)
Road-King is offline   Reply With Quote
Old 04-30-2014, 12:38 PM   #3
Member
 
Join Date: Apr 2011
Posts: 34
Yes, the other night. We were in AL when the storms went by. It worked perfectly on initial hookup. In the morning we had no power. I reset the power cord and it never went past delay. The maintenance guy checked the pole and it had power. We tried at the pedestal in the next site and it stayed at delay. We arrived at son-in-laws house and his 50 amp hookup stayed at the delay stage.

Tom
__________________
irish01 is offline   Reply With Quote
Old 04-30-2014, 12:44 PM   #4
Senior Member
 
Road-King's Avatar
 
Join Date: Jul 2012
Location: TN
Posts: 645
Here is TRC's customer support number 800-780-4324 x311.

I'm betting that your looking at buying a new surge protector. Maybe TRC will do something for you???
__________________
Russ & Kim
2014 Alpine 3600RS
2007 Dodge Ram 3500 5.9 4X4
2008 Harley Davidson Road King 105th Anniversary
(2011-5 bad year)(2012-40)(2013-45)(2014-23)
Road-King is offline   Reply With Quote
Old 05-03-2014, 08:35 AM   #5
Senior Member
 
Join Date: Jan 2014
Location: West Carrollton, Ohio
Posts: 473
I just purchased this Surge Guard Protector Model 34750. I am curious as to what you found out since there is the potential of me having the same issue. I nearly purchased the hardwire model made by progressive industries that comes with a lifetime warranty but was not enthuised about taking the under skirting apart under the camper to fish the wire up to where the control panel is for the monitor. So, I opted to go with this portable unit.
__________________
OKI Marine is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:49 AM.