Reply
 
Thread Tools Display Modes
Old 06-26-2012, 04:11 PM   #1
Junior Member
 
Join Date: Jun 2012
Posts: 4
Unhappy Trouble shooting

Hello everyone... I am new to the forum. I have a 2006 Sandpiper T34SP. We love it. Went to the lake last weekend and plugged into campground electricity. I went to turn the AC on and the whole main control board popped three relays...Can someone help in what could have done this? I would like to check as many things as possible before I re-connect the new one and this happens again. They are $300 a pop.
__________________

__________________
lacrista681 is offline   Reply With Quote
Old 06-26-2012, 04:13 PM   #2
Senior Member
 
Join Date: Aug 2010
Posts: 855
High park power? At least that would be my guess.
__________________

__________________
donn is offline   Reply With Quote
Old 06-26-2012, 04:17 PM   #3
B47
Senior Member
 
Join Date: Jan 2012
Location: Keller, Texas
Posts: 6,029
Quote:
Originally Posted by donn View Post
High park power? At least that would be my guess.
Did you have a surge protector installed when this happened? If so, what did it tell you? If not, then perhaps there is something wrong wth the CG power supply as suggested.
__________________
B47 is offline   Reply With Quote
Old 06-26-2012, 04:46 PM   #4
Junior Member
 
Join Date: Jun 2012
Posts: 4
No I did not have a surge protector. I will have my husband to check the amp out of the campground plug in.
__________________
lacrista681 is offline   Reply With Quote
Old 06-26-2012, 05:14 PM   #5
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,169
Quote:
Originally Posted by lacrista681 View Post
the whole main control board popped three relays... They are $300 a pop.
Don't know much about toy haulers, so this is new to me.

Initially, I thought you meant circuit breakers, but they don't cost 300.00 each (the entire power center can be replaced for under 200. (8900 Series Electronic RV Converter Center, 65 Amps - $184.95)

So, someone help me. What went wrong; where are the 3 relays; and why did it cost 900 dollars to repair/replace them?

If everything was OK until you turned on the air, you might have overloaded the campground's supply (if it was only 20 amps), or if there was a problem with the air, you should have blown two circuit breakers at most (main and air conditioner) and they don't get replaced; just reset.

If you have a 50 amp service camper plugged into a 50 amp supply and there was an open neutral (such that your camper was supplied with 220 VAC across the power center instead of 2 110 circuits, way more than the power center should have blown (like the air conditioner, microwave, etc).

In any case, it would be another case for a hard wired (or dangling) surge supressor.
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 06-26-2012, 05:31 PM   #6
Junior Member
 
Join Date: Jun 2012
Posts: 4
Thank you Lou for the info... At $300 I was taking about the whole converter. In TN we only have 2 RV parts shops. Camping world one and and mom & pop shop. It was about $289 plus tax. I will pass this info to my husband so he can check all this out.
__________________
lacrista681 is offline   Reply With Quote
Old 06-26-2012, 05:39 PM   #7
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,169
Do you have a 50 amp or 30 amp service?
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 06-26-2012, 10:10 PM   #8
Junior Member
 
Join Date: Jun 2012
Posts: 4
It is a 50 amp service.
__________________
lacrista681 is offline   Reply With Quote
Old 06-26-2012, 10:23 PM   #9
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Sounds fishy.
__________________
TURBS is offline   Reply With Quote
Old 06-26-2012, 10:37 PM   #10
B47
Senior Member
 
Join Date: Jan 2012
Location: Keller, Texas
Posts: 6,029
I should have asked earlier, but did any of your neighbors have any electrical problems that you know of?
__________________

__________________
B47 is offline   Reply With Quote
Reply

Tags
led pad

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:47 AM.