Reply
 
Thread Tools Display Modes
Old 04-22-2016, 01:03 PM   #1
Cpritzl
 
Join Date: Apr 2016
Posts: 1
Hydraulic Jack Problem

We had our camper stored all winter. We went to pick it up last night. We brought a generator with and plugged it in. Our hydraulic jack's wouldn't work at all, so we put jumper cables on the battery and jumped it but only one side of the jacks went down and one of our slide outs started to come out (the slide outs are not on the same switch as the jacks). Took the battery home and charged it and put it back in and still nothing is happening. Last night the back jacks went down fine. Could it be a bad switch? What are some of the suggestions to find out the problem.
__________________

cpritzl28 is offline   Reply With Quote
Old 04-22-2016, 01:18 PM   #2
Senior Member
 
Join Date: Apr 2012
Posts: 2,730
Deleted. Wrong thread. Not sure how that happened.
__________________

dustman_stx is offline   Reply With Quote
Old 04-22-2016, 01:34 PM   #3
Site Team
 
wmtire's Avatar
 
Join Date: Nov 2010
Location: Northeast Louisiana
Posts: 17,360
The site team has moved this question into it's own thread. Dustman, I think you were posting at the same time, which is why it got caught up in the move..
__________________
2011 Flagstaff 831 RLBSS

If I become a zombie, the last thing I'd wanna do is walk around. Are there any Reclining Dead?
wmtire is online now   Reply With Quote
Old 04-22-2016, 01:52 PM   #4
Phat Phrog Stunt Team
 
AquaMan's Avatar
 
Join Date: Apr 2012
Location: Tipp City, OH
Posts: 6,900
Quote:
Originally Posted by cpritzl28 View Post
We had our camper stored all winter. We went to pick it up last night. We brought a generator with and plugged it in. Our hydraulic jack's wouldn't work at all, so we put jumper cables on the battery and jumped it but only one side of the jacks went down and one of our slide outs started to come out (the slide outs are not on the same switch as the jacks). Took the battery home and charged it and put it back in and still nothing is happening. Last night the back jacks went down fine. Could it be a bad switch? What are some of the suggestions to find out the problem.
Are you sure your battery is good? If it was stored all winter and was dead, it may be shot. The hydraulics take a lot of battery power.
__________________
2016 Georgetown 364TS
2017 Jeep Rubicon Recon toad
Nights Camped 2018 - 23
AquaMan is offline   Reply With Quote
Old 04-22-2016, 10:24 PM   #5
2007 WildCat 32QBBS
 
05CrewDually's Avatar
 
Join Date: Jul 2011
Location: NJ
Posts: 2,095
Take the battery to the store and have it load tested. I believe that battery is not up for the task.
__________________
*Current: 2005 Ford F350 Crew Cab Dually 6.0 diesel 4x4*
*Retired: 1987 F350 Crew Cab Dually 6.9 turbo diesel
2007 Forest River WildCat 32QBBS
05CrewDually is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by


Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:18 AM.