Thread Tools Display Modes
Old 07-03-2016, 02:30 PM   #1
Junior Member
Join Date: Jun 2016
Posts: 7
2012 Flagstaff Aframe cool cat heat pump problems

HI my name is Dennis and have just joined for all the expertise of fellow campers. Please tell me anything I can do to troubleshoot my problem Thanks

Our unit quit cooling in Moab it was working fine then just quit blowing cool.
We had a power issue at the campground before Moab. The outside 30 Amp power box never kicked the breaker, it burned out a lead inside the box instead of kicking the breaker and the box stayed hot and they had to kill the power and install a new power box and breaker. Our air worked for about 2 days after that then just quit cooling. The fan works fine and when you turn it to cool I can get a click but the compressor never loads up and blows cool any ideas. I removed the unit today and it is really sealed in the hole. Haven't removed the plastic box that the unit is covered with, it has screws and plastic push in tab to hold it to the unit. I have priced a new unit from camping world for $981.08

OGUYSRULE is offline   Reply With Quote
Old 07-03-2016, 05:54 PM   #2
Senior Member
Join Date: Mar 2013
Location: Houston, TX
Posts: 1,588
I'd hate to say it's fried, because I am not an A/C tech. Call Dometic for the location of a local service tech to get the real answer. Could be a controler board or it could be the compressor motor, or....


2012 Rockwood A122S
2008 Toyota Tundra Double Cab 4X4

Former owner of a 2002 Coleman Niagara GTE
Pooneil is offline   Reply With Quote
Old 07-03-2016, 09:18 PM   #3
Senior Member
1A Camper's Avatar
Join Date: Jul 2013
Location: Denver, CO
Posts: 320
if you have the Dometic LCD thermostat try resetting it, in the off mode. Press the "+" button and while holding it, also press and hold the"ON/OFF Mode" button for 3 seconds. LCD will show "--". Press the On/Off Mode button again to turn system off. This completes the initialization.
We have had to do this a couple time when the heater system acts up, it may work for the AC mode also.

Steve and Adele
2014 Flagstaff T12RBST
2005 Toyota 4runner 4x4
1A Camper is offline   Reply With Quote
Old 07-06-2016, 08:37 PM   #4
Junior Member
Join Date: Jun 2016
Posts: 7
Click image for larger version

Name:	IMG_1595.jpg
Views:	44
Size:	353.9 KB
ID:	113301I haven't tried the thermosatat reset yet because i have removed the unit from the camper. I have tested the capacitor and its good and also the compressor windings numbers add up corectly. I have removed the thermosatat today and will hot wire it in the garage tomorrow and try the reset. There seems to be a stain on top of the fan motor and part of the verticle copper line that could be from a pin hole leak in the line not really sure.
OGUYSRULE is offline   Reply With Quote

2012, cat, flagstaff, frame, pump, a-frame

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:36 AM.