Reply
 
Thread Tools Display Modes
Old 04-29-2013, 07:27 PM   #1
Senior Member
 
LKicklight's Avatar
 
Join Date: Feb 2012
Location: CHATSWORTH, GA.
Posts: 1,121
Attwood Furnance

Our furnace in the Crusader 270RET is an Attwood Model 8513-IV DCLP...We have used it on previous outings with no problems..On this trip, after the unit had run long enough for the thermostat to kick the unit off, almost immediately we here the slight "bump" sound..about thirty seconds later, we heard a much louder sound that went "BAMB"....did this several times during the night..do not have a clue on what to check or what to look for...any ideas???
__________________

__________________
2500HD 6.0 Gas/Ext. Cab
2011 Crusader 270RET
2003 Sunnybrook T/T 30FIS
2012 Jeep Compass Limited
1985 S-10 One Owner:
LKicklight is offline   Reply With Quote
Old 04-29-2013, 07:28 PM   #2
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Quote:
Originally Posted by LKicklight View Post
Our furnace in the Crusader 270RET is an Attwood Model 8513-IV DCLP...We have used it on previous outings with no problems..On this trip, after the unit had run long enough for the thermostat to kick the unit off, almost immediately we here the slight "bump" sound..about thirty seconds later, we heard a much louder sound that went "BAMB"....did this several times during the night..do not have a clue on what to check or what to look for...any ideas???
Need to blow out the burner tube.
Sounds like you have friends and dust living in there !


Turbs
__________________

__________________
TURBS is offline   Reply With Quote
Old 04-29-2013, 07:48 PM   #3
Senior Member
 
LKicklight's Avatar
 
Join Date: Feb 2012
Location: CHATSWORTH, GA.
Posts: 1,121
Camp Site--

As I posted earlier about our campsite flooding, a first for us, know how turb feels now...we moved the 5'er about ten minutes after this photo, during the night that site was covered with water..not a good site...
Attached Thumbnails
Click image for larger version

Name:	P4280041.JPG
Views:	55
Size:	32.2 KB
ID:	29302  
__________________
2500HD 6.0 Gas/Ext. Cab
2011 Crusader 270RET
2003 Sunnybrook T/T 30FIS
2012 Jeep Compass Limited
1985 S-10 One Owner:
LKicklight is offline   Reply With Quote
Old 04-30-2013, 08:59 PM   #4
Senior Member
 
LKicklight's Avatar
 
Join Date: Feb 2012
Location: CHATSWORTH, GA.
Posts: 1,121
Atwood Rep.

spoke with the atwood rep tonight, he is afraid it maybe a propane leak in the valve on the unit...I am to knock on it with a wrench, clean the terminals off at the circuit board...if that does not fix it, he is coming out to remove the unit from the coach and take it apart to repair it...burner tube was blown out, no firm results...thats when I called in the calvary..any other good ideas..never had one to do this before, makes sense with all the banging going on..sounds right to me..kick



Quote:
Originally Posted by f1100turbo View Post
Need to blow out the burner tube.
Sounds like you have friends and dust living in there !


Turbs
__________________
2500HD 6.0 Gas/Ext. Cab
2011 Crusader 270RET
2003 Sunnybrook T/T 30FIS
2012 Jeep Compass Limited
1985 S-10 One Owner:
LKicklight is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:38 PM.