Reply
 
Thread Tools Display Modes
Old 04-03-2013, 07:31 PM   #1
Junior Member
 
Join Date: Jul 2011
Posts: 4
furnace ignitor clicking

The ignitor has started clicking in our suburban furnace. The heat is not turned on. I have to disconnect the power to the furnace to get it to stop. Any idea as to what is wrong?
__________________

__________________
jsklenar is offline   Reply With Quote
Old 04-03-2013, 07:42 PM   #2
Senior Member
 
Iggy's Avatar
 
Join Date: Jul 2010
Location: Desert SW - Arizona
Posts: 6,360
Hi and welcome

You never said what type of motrohome or trailer you have or its age.
Has the heater been working fine before this?
Have you verified you have gas?
Have you checked if the propane detector went off and needs resetting?

If those have been checked out and ok then I think.....
Thermostat may be bad inside because it is telling furnice to ignite.
That is the only thing to ell it to ignite. Now it isn't igniting may also be a control board failure because it is not turning on the gas.
Anyway check for a bad thermostat first then the control board..
__________________

__________________
2012 Georgetown XL - 378TS 60,000 miles
Life is a journey, not a destination !

Iggy is offline   Reply With Quote
Old 04-03-2013, 07:56 PM   #3
Senior Member
 
VinceU's Avatar
 
Join Date: Dec 2011
Posts: 3,502
Quote:
Originally Posted by jsklenar
The ignitor has started clicking in our suburban furnace. The heat is not turned on. I have to disconnect the power to the furnace to get it to stop. Any idea as to what is wrong?
Appears there is a "board/module controlling gas valve and ign of heater. Something may be shorted on the board causing igniitor to contine to fire. Your removing power sorta proves that.
__________________
VinceU is online now   Reply With Quote
Old 04-03-2013, 09:44 PM   #4
Junior Member
 
Join Date: Jul 2011
Posts: 4
It is a 2008 salem. The heater worked fine befor. I have gas. When the thermostat is turned on the blower comes on, the heat comes on and the ignitor still clicks. I was thinking it is the control board?
__________________
jsklenar is offline   Reply With Quote
Old 04-03-2013, 10:50 PM   #5
Senior Member
 
VinceU's Avatar
 
Join Date: Dec 2011
Posts: 3,502
Quote:
Originally Posted by jsklenar
It is a 2008 salem. The heater worked fine befor. I have gas. When the thermostat is turned on the blower comes on, the heat comes on and the ignitor still clicks. I was thinking it is the control board?
Why not call Suburban service folks and get their thoughts? I'm like you think all other ideas are eliminated. Disconnect power or the igniter will fail also.
__________________
VinceU is online now   Reply With Quote
Old 04-04-2013, 08:49 AM   #6
Member
 
dmer364's Avatar
 
Join Date: Jan 2013
Location: Pgh,Pa
Posts: 37
How long has it been sitting without the propane turned on? I know at the start of the season it takes a while to get the furnace,water heater,stove and fridge to light. The propane will bleed off over time.
__________________
dmer364 is offline   Reply With Quote
Old 04-04-2013, 02:12 PM   #7
Junior Member
 
Join Date: Jul 2011
Posts: 4
There is plenty of propane. The ignitor is clicking with the heat turned on or off.
__________________

__________________
jsklenar is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:53 PM.